Dear Support Team,
I have had the GSC3570 in use for months and it worked quite well except that every 3 days a reboot would have to be made. With firmware version, when someone pressed the button on the GDS3710 door intercom, the image appeared first and you could choose to answer or not. After the firmware update (Relaese, the GSC3570 behaves differently. When ringing, the image no longer comes at the beginning and only after you have confirmed the call, the image of the caller appears later. How can I get back the previous function with the appearance of the picture first. I have already done a reset and tried all possible configurations. Unfortunately it does not work. Could you please help me with the solution.
Best Regards


That feature is called “preview” or “early media” in SIP term. I don’t think this is related for GSC3570 firmware.

You can easily test it by configure the doorbell call to be IP address instead of SIP extension (if you are using SIP Server or IPPBX). If using IP Pairing call (direct IP call) the “preview” works, then that means your SIP PBX (if it is UCM) need firmware upgrade.

If still have issue, please open a support ticket at HELPDESK.

Hope this helps. Thank you for using Grandstream Access Control Products.


Dear GS_Guy,
Thank you for the quick reply. Unfortunately, in my previous mail I specified a wrong firmware version. The correct firmware version with which it worked properly is the version and not the version
I use two GSC3570 and have updated only one with the new firmware version The version where it worked well is version, but here is only the problem that every 2-3 days the device hasneed to be rebooted, because calls to the GSC3570 do not ring. The configurable reboot feature is unfortunately only available in the new firmware versions but not in the old version (
I have not configured a SIP server…
I have configured only IP Call in both firmware versions and compared all possible parameters between the two software versions and they are identical.

Best Regards,



The firmware works fine with me with IP call for the “preview”

  1. Have you factory reset the GSC3570 after upgrade from to as per release note mentioned?
  2. Have you configured “External Service” in the GSC3570, refer to below screenshot:

If this not working, please open a support ticket at HELPDESK, make sure to export the CFG file and upload to the support ticket.



I have reconfigured the device as you described and made a reset. Unfortunately, the behavior has not changed and the “preview” function is not activated. I will open a ticket at the helpdesk. Thank you very much for your good support.
Best Regrads,


I have the same issue. My GSC3570 doesn’t preview my GDS3710 when someone push the doorbell.
Have you find a solution with the helpdesk ?

Best Regards


This is either a configuration issue or SIP proxy issue. Please try configure using direct IP call to rule out Proxy issue. whether using configuration listed in above previous posting reply via direct IP call working first. Good luck!