GS Wave unregisters/loses connection with VOIP server (Anveo)

beta-club

#1

I have been using GS Wave for iOS (v. 8.1) for several weeks now. The app seems to randomly disconnect/unregister from the server and will only reconnect if I close the app and restart it. This is a problem of course because I don’t know when the app is disconnecting and end up missing calls.

It seems to happen most consistently when changing networks, i.e. from WiFi to cellular.

I also don’t see any way to change the re-registration or keep alive settings in the app. Is there any way to do this?


#2

I can’t even get mine to register.


#3

I am experiencing the same issue and couldn’t find the option for the iOS app to run in the background. Would really appreciate a solution or response.


#4

Any update on this issue?

I am now running an iPhone 6 with iOS 10.

Some additional notes from testing:

  1. The app does not crash when the phone is placed in airplane mode.
  2. With the app running and phone then placed out of airplane mode, the app will continue to run and eventually time out with an error "Registered failed to SIP: account name.

I did not experience this problem on an iPhone 5 that ran iOS 8. I specifically did not upgrade this phone knowing this was an issue with later versions of iOS.
This is definitely a software issue between Apple and Grandstream. I have not seen any way to enable any kind of logging to see what causes the app to crash.

Grandstream seems to be one of the best softphone apps on the market, so it would be ideal for this issue to be resolved. Unfortunately Grandstream has not shown any interest in addressing it.


#5

I have the same issue, the application los the registry when the user lock del iPhone, and only registry again when open the application.


#6

I know this is a bit of an old topic, but the issue still exists for me. Hoping to add some more data points here and find out if anyone has found the magic combination of settings.

I have Grandstream Wave on three smart devices registered to an UCM6102. The android stays reliably connected but only if I leave the registration notification turned on. The ipad is somewhat better, but still disconnects periodically. The iphone will looses it’s registration when locked for a period of time (still narrowing that down). It eventually re-registers when the phone is unlocked or you open the GS Wave app.

I have keep alive turned on and set for 20 seconds. I’ve played around with the registration duration but went back to the default of 60 minutes on my android and it stays connected, but not the iphone. One difference between the android and iphone app is there is no “Enable Session Expiration” on/off button for the iphone. It is set to off for the android.

I have notifications turned on as well as the “Background App Refresh” set to on for GS Wave on the ios devices.

Thanks
Gary


#7

I opened a ticket with GS. Ticket #: 20170606125009

They confirmed the issue and it’s been sent to the developers. No word yet on when a fix will be available.


#8

We are having this problem too! It needs to be fixed asap!


#9

Grandstream closed the ticket due to inactivity so I logged and posted a comment just to get it re-opened. It would be nice if they closed a ticket only when it was resolved and not just after a certain time period. Who runs a trouble ticket system like that?


#10

I am using GS Wave 1.2.5.3 on iOS 10 and have the same issue. Seems like it work fine in iOS 9 but not in iOS 10. Hope Grandstream can fix that soon


#11

We’re experiencing the same issue. Please fix asap!


#12

I’m facing the same issue.


#13

Enter SETTINGS at the bottom right
Enter Account Settings
Enter Your Account
Switch OFF "Enable Session Expiration"
Make “Register Expiration” to 10 m
Make Sure you have chosen the right "Transmission Protocol"
Use the Left Flash to Leave the Setting Menu x 2 times

Close GS Wave and reopen it.

LET ME KNOW HOW IT GOES …


#14

Hi Kamel, that’s only an option in the Android version, I believe – not in iOS.


#15

I’ve since switched to Sangoma FreePBX and GS Wave works perfectly.