GS Wave over VPN - One-Way Audio


#1

Hello.
Help, please, solve the problem.

PBX UCM6510 V1.4B
v.Boot 1.0.16.1, v.Core 1.0.16.3, v.Base 1.0.16.20

GS Wave 1.0.3.16

When connecting GS Wave via VPN, the client registers to the IP PBX not with the address received from the VPN server (internal), but with the external one, which is provided by the 3G-operator. This can be seen in the properties of the extension number. Naturally, such a connection does not work, more precisely, it works in one direction, from the client to the station, but not backwards.
VPN is built using CISCO (AnyConnect and CISCO-Firewall). With other VPN clients, for example OpenConnect, the situation repeats. The VPN server issues the correct address from the specified pool to the client. Through the VPN connection, the client works correctly with any applications and data on the local network, and only the GS Wave is registered at the station with an external client address.
I do not find problems with the VPN channel, and GS Wave also tried with different settings. I tend to think that something is wrong with the settings of my IP PBX.

I would be grateful for any help.
Thank you.


#2

try start rtp keep alive.
PBX -> sip settings -> tos


#3

It’s a NAT issue.

  1. Set the Outbound Proxy in GS Wave to the external ip address and the port the PBX is located on. Looks like XXX.XXX.XXX.XXX:XXXX

  2. On the PBX, go to PBX > SIP Settings > NAT and create a local network address. Enter the ip address of the PBX. Save then reboot.

  3. Open ports for Signaling on your external router and forward to PBX.

This solved my one-way audio issues.