GS Wave Only Works on Wifi


#1

I’m having troubles setting up the Grandstream Wave App. My phone is a LG Phoenix 3 (android) on AT&T network.

Problem 1) I configure two accounts in the app (one for private, one for public). It connect to my extension perfectly while I’m connected to the network through WIFI (the app automatically changes your IP and Port to the device that your using). As soon as I disconnect from WIFI, my extension (104) IP and Port will not default back to my GXP2124 phone’s static IP. The only fix I’ve found for this is to reboot my GXP2124 and it returns to normal.

Problem 2) Grandstream Wave does not work on the public network if I turn off WIFI on my phone.
I have a UCM6204 connected through our office network using a Peplink Balance 20 Router. I’ve tried a variety of things but nothing has worked. I thought if I configured port forwarding it would fix some problems but nothing I do has helped.

I’m hoping there are others that have found a solution to this problem.

Thank you for your help!


Gs wave on wifi cs cellular internet
#2

how did you set up the GS Wave, either manually or via email?
configure the codecs correctly (disable all and enable only g711 if possible)
Is the firewall / router set up correctly?
keep alive enabled?
side gs wave put the stun -> keep active
I have never had problems on GS wave both locally and remotely, but above all remotely you need to do a lot of tricks.
For security reasons I do not recommend opening the 5050 and the rtp ports to the whole world.

p.s.: GXP2124 what fits us with the gswave?

Damiano


#3

Damiano,

I setup my accounts on GS Wave by sending the email notification to myself from my extension after logging into my admin account in the UCM6204, printing the page, and scanning the QR codes. I have set NAT Traversal to “Keep-Alive”. Still no connectivity.

I find it odd that my private account (wifi) has a sip port of 5060 and the public sip port is set to 5062.

Do you think this might be the issue? The sip port line is gray on the app and won’t allow me to change it.


#4

see that it is not enough to create an extension and send an email and record the qrcode, have you done the correct nat?
I also asked you for other things


#5

Also, under Preferred Vocoder - there is no g711 option.


#6

g711a / u = PCMA / U
I think you lack the basics to get results on the SIP protocol


#7

In your sip server field use :5062 after the server name/ip address to change the sip port.


#8
  1. what version of the Wave is installed? 1.0.3.19 is the latest.
  2. when you indicate that when using Wi-Fi you see 5060 and when using AT&T you see 5062, exactly where are you seeing this?
  3. when using AT&T, does the WAVE show registered in the UCM?
  4. do not change the sip server port to 5062 just yet. leave the sip server setting to your publicIP:5060 on both accounts 0 2124 internal and the one for external.
  5. Do you have port forwarding enabled on the peplink for 5060UDP to the UCM and is the SIP ALG disabled? If not, please do so.
  6. Do you have the RTP ports also forwarded. If not please do so.

We will address the security issue after we understand what the setup is and have something we can work with.

With regard to the 2124, look at the extension settings in the UCM and see how many concurrent registrations are allowed. This is located in the Extension’s User Settings. If set to 1, then increase the setting to at least 2. Each device that you want connected using the same extension number at the same time is a registration and for security the UCM is limiting the number of devices to 1 as a default, So, you need 1 for the 2124 and 2 for the WAVE.


#9

I tried that and it didn’t help


#10

Not a surprise. Port forwarding is definitely necessary, but you’ll also have to reduce the size of the RTP pool and forward these ports are well, and even if all your port forwarding is done correctly it may or may not work depending on your cell phone provider and whatever transparent proxy and other “features” they have.

Your best option is a VPN to your office, and then you access your UCM by the inside IP


#11

You tried what ? There were several suggestions from various folks.


#12

I had the same problem before. We now use Zoiper and it works just fine using public IP that has been port-forwarded.


#13