GS Wave on Android 10, Oneplus 6T - no ringing when app is not open in the front


Since my latest Android update I experience an issue with the GS Wave app:

When the app is open and in the foreground and a call comes in, then the phone rings and vibrates (as set up in the account settings). That works even when the screen is off and the phone gets locked.
When the app is not open and in the foreground, then there is no ringtone - nut I can see in the notifications that it say GS Wave: Call Status - One ringing line… When I tap the notification, then the call window opens and the ringtone starts.

I first thought it might be a problem with the app getting killed, so I deactivated the battery optimizer for the app and the app now keeps running in the background. When I call the notification even shows on the lock screen that a call is incoming.
The app has all permissions (even allowing display over other apps)

Phone: OnePlus A6013
Android: 10 / OxygenOS v 10.3.0

I hope somebody can give me a hint where to look for a fix.
Thank you!


I can confirm your findings as I have One Plus 6 as well.

I am of the opinion that there is no fix as the OS is controlling how the app is allowed to notify. However, in the notification page, you can set a so-called ring tone which is actually nothing more than a short tone such as those heard when receiving a text. Easy to miss, but that appears to be all there is.

Just my opinion though, but there are no settings in the Wave itself that I see to alter the behavior.


Thank you - I was afraid that Android 10 or OxygenOS has become a lot more restrictive.
I’ll use the notification ping for this as you suggested (thanks!) and hope that OP will provide better permission settings in an update.


I’m having tonnes of trouble with my GS wave applications I’ve deployed. Some apps have been working well for many months, all sorts of people over Wi-Fi and cellular where the app has just stopped being reliable.

I’ve been trying Bria and Zoiper but don’t like either.

Any thoughts on SIP application in general? Is there a bullet proof app out there that just works?


Not really. There are some that work quite well, but they are proprietary to the PBX make as they don’t use the standard SIP signalling.

The issue is multi-fold -

  1. Multilple cellular carriers, some of which seem more forgiving of SIP and NAT, some not so much.
  2. Various NAT situations to include the differences between Wi-Fi sites and where some purposely block SIP (seems to be much less now, but in hotels a few years back, some would block SIP in order to (hopefully) force you to use the in-house phone for a charge)
  3. IPv4 and IPv6 and how one decides to allow or not, an IP to pass the firewall.
  4. Various cell phone makes and those that use stock Android and those who modify. Apple with its battery saving function.
  5. Various versions of iOS and Android (and the upgrades that occur for security, stability to the existing OS as well as version upgrades in some cases) and the breadth of which users may expect them to function given the age of the cell phone in use.
  6. Signal quality, carrier modulation (gsm, tdma, cdma,), coverage mode 2g,3g,4g, LTE, VoLTE and now 5g and what the phone supports.
  7. Transport mode - TCP, UDP, TLS,

I could go on and on, but all I really want is to -
Do video, have presence setting capability (away, available, etc), BLFs out the wazoo, chat, control doors, turn on the coffee pot along with the same functionality that the receptionist has when using their GXP, GRP or GXV with 4 expansion modules and using an unsupported BT headset on my dual core, 4GB memory cell phone that has 100 apps installed with around 20 of them running in the background at any one time, while using the GPS and listening to Pandora at the same time while SUCCESSFULLY and AUTOMATICALLY resolving all the issues described. Outbound faxing would be nice as well.

What could possibly go wrong?


So… You’re recommending I tenderize my phone to make it faster?


I hadn’t thought of it that way, as I was not thinking of your phone, but the phone of the clients that insist on using a softphone.

Just consider the following advantages -

  1. Fewer troubleshooting calls regarding softphones (imagine how much time you will have to deal with really pressing items such as changing ring tones, adding BLFs or dare I say it, dealing with fax issues.
  2. You can Implement the program into the CostWise Business Consulting Wellness Program
    a) reduces stress and tension
    b) improves circulation
    c) burns calories
    d) builds muscle (use other arm/hand in equal amounts)
    e) provides for a sense of well-being and calmness afterwards.
    f) start up a second business line and sell memberships to “Smash Gym”
  3. Allows customer to more so, once again, reach out and communicate with their loved ones and other human beings face-to-face (no more dinner table phone play).
  4. If tech withdrawal occurs and they refuse therapy and must have a cell phone to stop the drooling and tremors, then at least they have an opportunity to get a more up-to-date and better model, which will sustain the Wellness Program for years to come.


This is not just a one plus issue. I have it on a Nokia 7.1 with Android 10.
Somehow this would need to be fixed.


I had the same problem when i installed GS wave app on my Samsung Note 10 today. After digging around in the settings i changed the permissions to appear on top and changed the “Change systems settings to allowed” and now the app is ringing when my phone is locked and behaving like a normal phone. I changed the “Change system settings” permission to off and the app still works fine. Not sure if the app needs that permission enabled permanently but for me it is currently working.

I would think the permissions on android 10 devices would be the same but i can’t confirm.
Hope this helps somebody else.


Thanks Steve07. Your fix worked for my Samsung S10+. Here is a pic to make it a bit more clear what settings need to be changed.


I have a Note 10+ Android 10, and those settings aren’t available. I can’t seem to find any settings that will allow it to ring in the background. It’ll show a notification and make a notification sound, and then ring when I open the app… but it won’t just ring when the phone is locked or app is in the background.


Samsung S9 just upgraded to Android 10. Embarrased myself with a demo that failed, GSwave would not pop up and ring…shame on me for not testing after the update.

Using what was said above I went into the app settings and changed the following settings:

App Info -> Advanced ->
Draw over other apps to “ON”
Modify system settings to “Allowed”

Force stop then restarted, working fine so far for now.


That worked for me. Thank you!


So we’re having similar problems with a number of people’s phones. Even if we turn on “draw over other apps” and “modify system settings,” it seems we only get ring notifications if the phone is on and the Wave app is in front.

My personal test phone is a Galaxy Note 10+ running Android 10. Unfortunately, I don’t currently have an older phone to be able to test with at my disposal, though I will grab a couple tomorrow.


Have you tried force stopping the app after making the settings and then re-launching the app again? I had the same issues on the same phone until I force stopped and re-launched.


We force stopped, deleted, and reinstalled.

Working on some theories at this point. Will report back what we find.