GS Wave - No Audio over WAN, One-way Audio on VPN


Finally go GS Wave to register. I have full audio both way while on the LAN with the PBX. When I move to WAN it registers and connects calls, but I have no audio in either direction. I tried it over a VPN and now I have audio from the desk phone to the mobile, but no audio from the mobile to the desk phone. Any help on what to check next is appreciated. Thank you!


You most likely need to forward these ports on your firewall from WAN to PBX IP:

SIP RTP * 10000-20000 WAN to PBX IP
SIP TLS * 5061 WAN to PBX IP

Restrict those ports to just the IP of your mobile phone (if possible).


Should have mentioned, I have all of those ports forwarded.


I have same problem :frowning:

i follow this post


maybe issue is on telecom provider side. sometimes they block some ports or drop some Voip packets


Put the local lan segment on the remote VPN side into the ucm, pbx settings, sip setting, nat at the bottom where local lan is located.


Any cure for this? I also have no audio.
Seems to be a recurring theme.

I have tried multiple wireless networks; no change. I tried 4G; no change.
I tried UDP, TCP and TLS; no change.
I’m connecting to 2Talk here in NZ: the Grandstream physical setup works flawlessly… on same network.

It worked once upon a time… though, at least a year (maybe two) since I tried.

Calls “work”… everything rings… I can even hear the ring tones.
But no voice. I can’t hear them; they can’t hear me.

I know its free… sort of. I use the app because I have Grandstream hardware for physical phones… so, having app on my mobile completed the solution.


you need scenery and details



I had suck months with same problem. Local network calls is working? The problem is with port forwarding. You need to CHECK OUT the box called “direct call” from the pbx menu. Because when you set up the port forward its work while ringing, but when the connection is established, the system use another route (with closed ports). When you check out the direct call, the system use its route, and if your port forwarding is well set, its works!


scenery and details?


Hi Masonic, I’ve scoured the Grandstream Lite option pages… couldn’t find a “Direct Call” checkbox… or even a PBX menu. These old eyes aren’t what they used to be.
The Grandstream HT802 appliance is working on the same network; but Grandstream Lite softphone doesn’t. I’ve compared settings they appear to both have, but… nothing obvious.


the reader must understand in order to give you advice


More than happy to expand. Are there specific details?
My problem:

  • Grandstream Lite is connecting to my SPI provider… account “dot” is green
  • I can dial a number; the connection succeeds… the phone at the other end rings
  • however, no audio: no ring tones, no voice in either direction

My scenario:

  • Grandstream Lite on Android, latest version
  • I have a Grandstream HT802 appliance… that works
  • standard SIP account… my provider is not in the list of providers
  • it worked well when I first installed the softphone… a year or two ago… had not tried again until this week

Things I tried, based on above discussion:

  • with or without proxy
  • I’m using UDP, but tried TCP and TLS; my HT802 is using UDP
  • the problem is identical regardless of the network: tried 4G mobile, and 3 different wireless networks

PS. Just installed Bria Solo. Works. Wasn’t impressed with voice quality, but it worked.


Use a 3rd party SIP application like Zoiper / Counterpath


Heading that way. Tried Counterpath/Brio today.
Hoped GV Wave could work. Their hardware has been solid, so…
I’ll persist if solutions exist…