GS Wave does not ring when iPhone idle - appears unreachable in FreePBX

ip-communications

#1

This has been an ongoing problem, even with the new version of Wave:

Our VOIP backend is Sangoma FreePBX 13.0.190.11.

On an iPhone 6 running IOS 9, when the iPhone is idle and locked, the GS Wave softphone does not ring at all, and appears as UNREACHABLE in FreePBX but still listed with an IP address. I have tested this using 3G connection and LTE connection.

The issue may be with registration period timeout, but there is no way in GS Wave to set or check the registration period. I have tested with ZOIPER and does not have the same problem. Once the app stops receiving calls, the only way to fix the problem is to close/restart the app, even though Wave displays the green circle indicating it is connected to the SIP server.

I have also tested using Stun server and keep alive settings, and both have the same result.

When the app is first launched, it works fine, and if the phone is kept open, it works fine. But as soon as the phone locks, the app no longer receives calls. There are no problems making outbound calls.

Has anyone else had this problem on an iPhone 5 or 6?


#2

We are experiencing this same problem. Did you find a way to fix this?


#3

same here also but with android : When the app is first launched, it works fine, and if the phone is kept open, it works fine. But as soon as the phone locks, the app no longer receives calls. There are no problems making outbound calls. After an outbound call, the app works fine again.


#4

Hi Guys

I have the same problem on a Ubiquity Wi-Fi network. Any workaround here please?


#5

I had the same problem. Using GSWave 1.0.3.19 with a Kamailio Server and Android 8.0.0. Phone didn’t ring unless screen was on and unlocked. I think this is because of the Android “Battery Optimisation” feature. I disabled “Battery Optimisation” for just the GSWave application and it seems to be working so far.


#6

said so it seems that your mobile phone standby “breaks down the services”, the classic of mobile apps.
Try to see from your phone settings if you can “put exceptions”


#7

I have the same problem here with GS Wave for Android.

Wave doesn’t try to register periodically, at the same time it doesn’t answer to OPTIONS packets from the PBX once the phone is in standby, so the PBX thinks it’s gone. Then a call comes and the PBX doesn’t even try to contact it.

Perhaps this was done on purpose in order to save battery, but I think it might be breaking the SIP specification and evidently causes problems.

A workaround is to prevent the PBX from checking the extension periodically, in Asterisk this can be controlled with “qualify_interval” and “qualify_timeout”.

But this is a bug in Wave, it should be solved.

By the way, Linphone works fine even when the phone is on standby, you might want to try it.