GS Wave App - Smartphone doesn't ring


Hello there!

A few months ago I tried the GS Wave app for my Android phone. It is a Samsung A50 and it all worked properly. I didn’t use the app for about two months and now the phone doesn’t ring anymore if someone calls me and the screen is locked. When the phone is active anything is fine. There are many of those threads here where people have problems with getting notifications while the screen is locked. I tried all of the recommended things but nothing helped.

So far I reinstalled the app, deleted the account, deleted all data from the app, created a new account, changed in the phone settings that the app may change system stuff and appears on top. Nothing helped.

Does anyone have a clue what to try next?

Any help is appreciated!


Lets clarify : you are talking about gs wave app or about gs wave light ?
And what is your PBX version ?


Hi, I am talking about the GS Wave Light smartphone app. What exactly do you mean with PBX version?


Modern IOS and androids suppress background activity of applications. So wave light can not normally oparates in background any more.
You need application that supports push mechanism for notifications. Like gs wave app and gs PBX 63xx series.


So there is no way to make it work?


Perhaps open a ticket with Grandstream.


It seems I just found a way to make it work. I had to do some additional stuff in the battery settings. For those who are interested, I found this general background running information on the following website: