GS Wave and no audio on either side with VoIP.ms when on cell


#1

I’m using Android and this used to work.

Right now if I’m on WiFi I have few issues, but I have no audio on either side with cellular data is used.

Zoiper works just fine but it constantly makes notification sounds for unknown reasons and it drives me crazy (same sounds as my emails so I constantly think I have new emails lol)

I’d like to get gs wave working on cell data again so I can be fully functional.

Any ideas?

Gilligan


#2

how is it possible to give you ideas if you do not understand what voip server you use, what network infrastructure scenario do you have etc …?


#3

What would you like to know.

I stated that is VoIP.ms (in the subject), it’s the Houston server if that helps you.

I stated that I’m using the cellular network. 4g TMobile if that helps.

What else can I tell you that would help you help me?

Houston and TMobile is really the only other variable that I had not included originally.


#4

mobile operators often filter VoIP, find out about this


#5

As Mentioned I am successfully using the same sub account on zoiper (another shift phone application) on the same phone.


#6

Does Voip.ms support TCP as a transport?


#7

Yes they do.

But changing that does not make a difference. :frowning:


#8

Make a call and do the debug and post.


#9

I’m having the same issue. I’m on T-mobile so I do wonder if they are filtering. Here’s a debug: https://pastebin.com/7VYKV8KK

Any ideas?


#10

Simply post the pcap file if possible,


#11

Hi, does it generate its own pcap file or do I need to install a packet sniffer?


#12

Interestingly, when I turn on SIP encryption on voip.ms and enable TLS on GS Wave, it connects and then instantly goes to a busy signal with a ‘488 Not Acceptable’ error.


#13

So the summary is:
UDP – call connects, silence on both ends
TCP – call connects and then immediately hangs up
TLS w/ encryption turned on at voip.ms – call connects and instantly goes to a busy signal with a ‘488 Not Acceptable’ error


#14

@luckyidea, but Zoiper works… so I don’t think they are filtering. :frowning:


#15

Zoiper uses its own STUN server - hint hint…


#16

Zoiper works for me on desktop but it also suffers from the same issue as GS Wave does on my Samsung S20 on Tmobile.

Does anyone have any android-based soft phone working with voip.ms on T-mobile? If so, please share your configuration details.

thanks


#17

Do you think it is the Samsung - i think that also has a SIP client installed on it which might be interfering


#18

Well, I have android (One Plus 7 Pro) and I HAD no problems with GSWave… still have no problems with Zoiper.

Standard settings have worked and are working for me with Zoiper.

Just need more than one SIP account and GSWave is what I prefer, but it’s not working.


#19

@scottsip, I turned on the STUN server setting for my GSWave and it didn’t help.

Not sure if that was what your hint was suggesting… I still can’t get it to work though.


#20

@gilligan8 who is your mobile phone provider? I’m still leaning toward this being a T-mobile issue.