GS Wave and Android 9 (solved)



So i’ve been using Grandstream Wave for around a year now with no issues. It worked fine both on the internal network and external for the entire period

Yesterday my phone (OnePlus 3T - A3003) update to Android 9 and now i’m having odd behaviour with GS Wave

If i turn off my wifi and use my mobile data it connects through fine. If i VPN my phone while on mobile data to the internal voip network, it is still fine

If i connect to any WiFi network internally or external at all, even ones that worked fine yesterday and i control, it fails to register. Even using wifi then VPN’ing to the internal network does not work

The remote server is an Asterisk box as it always has been. The only change to occur between it working and not is the upgrade of android. I have ensured that GS Wave has no battery limits on it or anything else like that and can see it trying to connect

I have done some tests today and over mobile data everything is fine. The second i switch the wifi, my PBX starts to warn that the device is trying to connect too much with no valid login and instantly starts to rate limit the device and in the end results in tt being blocked

This has only started since the upgrade so i’m wondering if there is a bug somewhere or something i need to change? I don’t even see login failure attempts in the asterisk logs and have tried white listing the wifi ip and this doesn’t help either

Its kind of like something in Android 9 is different about the wifi and is messing up the data being sent by the app?


Edit: using GS Wave in case that helps

This is broken due to enabling Wifi Calling
Regardless of the settings, if this is enabled it blocks all outbound voip connections. Disabled Wifi Calling fixed the issue it seems