GS Upgrade tool not working


Hello, I want to upgrade my GS 3710. However, since some version this does not work as before. The upgrade process hangs after login and server start. Can anyone help me or may have had the same problem.


What is the HW and FW version?


HV is V1.6A . The actual FW Version That was last version which have been updated. Since that version update didn’t work any more.


Since this version the update is carried out directly from http, no longer with Upgrade tool.


Hi Eric, tried to update with the recommended settings but without success. Is there any Dokumentation about the proper settings. I tried it with information from Grandstream “SIP Device Provisioning Guide” but it doesnt work. Dont know what to do any further.


If you have a not bad internet connection, you can try to point to Grandstream to get the device upgrade.
Using HTTP and configure firmware server path to:
Save and reboot, also leave enough time (say 1 hour) for the process, make sure no power outage during the upgrade process.

If you have a very old antique firmware, or stuck at the transition firmware, please read the Release Note to find the around version of the firmware, open a ticket at HELPDESK to get Grandstream Support Engineers to help you, if pointing to Grandstream firmware server path NOT helpful.

Hope this helps. Please share whether it works. Good luck!


As explained above, you should no longer attempt to update with Uprade tool, your version, being greater than, is updated with the GUI, or as suggested by GS_Guy: with
Why make it simple when you can make it complicated?
If I read your requests correctly, you prefer complicated!