GRP2613 Stop ringing after some days

bug

#163

My rant (and certainly not directed at you (Telefonix) or any other forum user, but to GS yes) -

My take is that regardless of what type of file, or where derived, if the device accepted it and those tones worked for some period, then there should be no reason that they should quit working sometime later.

GS has had ample time to work this issue, test all the scenarios to include what file types, formats and file sizes should work while rejecting the rest programmatically or, like in other cases, the phone takes the tone but it fails to work from the get go and never works.

As it stands, if it seemingly works, you have no reason to think that it won’t going forward (at least not until recently).

Many have begged for a different or added set of GS supplied ringtones for years. This is nothing new; yet GS has not favored us with same.

This thread goes back to May 20th; yet here we are today ( a couple of days shy of 6 months) still looking for answers (in all the wrong places?) and only wanting something that we can feel good about offering to our clients knowing that it will work and not cause us undue/unwarranted/unwanted service calls for issues that we can’t fix.

I have quit deploying the GRP and have moved on to to something else in the meantime. I will await a true fix before installing more and I will continue to deal with those already installed hoping that a fix will be forthcoming soon.


#164

I don’t know if it’s the same problem, I have just updated the local GRP2613 that regularly works for 4 months to version 1.0.5.67, the phone after the update is frequently deregister, I realize that you register from public IP instead of local IP, As if you have activated it Stun, practically the update has changed the “Nat Traversal” parameter in AUTO, I had set it in Keep Alive.
Return to Keep Alive and now it’s ok.

Damiano


#165

This is still happening on 1.0.5.67.

I don’t use GDMS and I don’t upload any ring tones to the phones, the only ring tones used are the 3 choices within the firmware. So a lot of the comments above can be ruled out.

We have multiple sites where the main answering point stops audibly ringing due to this bug. Our customers are not happy.

GS need to put more resources into fixing the problem ASAP, this forum thread started in May. Can anybody believe that it takes this long to fix a firmware bug?

It seems to me that there is no difference between stable is beta these days.


#166

I’ve stopped selling the GRP until this is sorted out. Too many unhappy customers. Admittedly I’ve only sold a couple hundred so far, so this won’t make a dent in any sales, but really, this should have been sorted out months ago. I would imagine no carrier would be pushing these either.


#167

There is a later Beta out than .67.


#168

Great.

But we need the issue fixed. A crap-load of betas have addressed the issue in the “bug fixes” notes but NONE of them have actually FIXED it.


#169

True and I agree, but until you try it, you don’t know if it’s fixed or not. I have it in 4 sites now, and so far no issue, BUT, to your point, it takes time, not all scenarios may be the same, and…what other choice is there other than using a different model or brand?


#170

Is there a chance that the customer is turning the volume all the way down?
I see it’s possible. Maybe Grandstream needs to remove the 0 volume level on these phones.


#171

No, it’s not that. The issue is with the use of Distinctive Ring Tones.


#172

We are on the latest beta 1.0.5.93 and our phones still stop ringing. Updated my support ticket as well.


#173

If I’m not mistaken they wrote something to solve about personalized or custom ring


#174

I have not seen anything official to fix this other than the last 3 or 4 firmware releases that claim to fix it. I looked at the fixes in the forums but we either had those settings set already or they didn’t help. As of Dec 1st support was still acknowledging the issue hadn’t been fixed and was still being investigated.


#175

Are you using custom ring tones that you loaded into the phone?


#176

Yes we use one custom ringtone for incoming calls. Our internal extensions are setup with a stock ringtone when calling internally and that goes silent as well. The custom ringtone seems to be the root of the issue. I would gladly use a stock ringtone if the phones came something normal or doesn’t sound like an outgoing ringback tone.


#177

you the pointer written above that could be a problem of custom ring


#178

I have not tried 1.0.5.93, last I tried was 1.0.5.66. After trying multiple versions and being told it was fixed and even different ringtones made by grandstream support themselves the issue remained. I bit the bullet, and disabled all ring customizations, No distinctive ring for internal calls at all. No custom ringtones at all. Removed the ringtones and pcodes from my zeroconfig, defaulted all the GRP2615 and reprovisioned and came up with default system ringtone. Customer is happy and hasn’t complained since.

I am not sure if the issue is still the problem of the custom ringtone at this point or if grandstream has an issue with distinctive ring.

I don’t have time to test such a basic thing as a ringtone that should work. All the systems I have ever programmed we had no need for custom rings, some built in traditional sounding office telephone rings that are certified and tested to work would be nice and then I believe this custom ringtone feature would barley be used.

I also can’t believe that in order to have internal calls ring differently you have to program down to the phone level (in this case zero config or GDMS) with the UCM system. It should just be a default feature. Very common among many big systems out there.

Anyway happy testing I hope grandstream narrows it down fast, I will be watching this thread and wait for success.


#179

Приобрели несколько аппаратов GRP2615 и GRP2612P, у всех регулярно пропадает мелодия при входящих звонках. Помогает только перезагрузка аппарата.
Как, сука, можно за пол года не исправить такую важную проблему для большинства!?
*Мелодии используются только встроенные в прошивку, проблема на всех аппаратах проявляется одинаково и с одинаковой частотой.


#180

you should write in English


#181
  • For those who got banned in the Google.translate

We bought several devices GRP2615 and GRP2612P, all of them regularly lose the melody when receiving calls. Only restarting the device helps.
How can vendor not fix such a problem for the customers in half a year !?

  • Ringtones that we are using only built in the firmware, the problem on all devices manifests itself in the same way and with the same periodicaly.

#182

Can’t defend GS in this case as the issue is as you say. I can only point you to the latest release (.93) that makes reference to steps to fix the problem, but whether or not it does in all cases…only time and testing will tell.