GRP2603P phones sometime dont change state



Recently we have bought several dozens GRP2603P phones and all of them sometime have two issues:

  1. The phone is idle. After handset was up, phone remains in the idle state (no tone, no screen change). If push and release hook switch, phone goes to dialing state.
  2. The phone rings. After handset was up the phone keeps ringing. If push and release hook switch, phone stop ringing and goes to call state.

IP server is FreePBX 15.0.21 with Asterisk Version 16.20.0.
Phones’ FW is latest, but problems persist on beta too.

I have tried lot of settings variants, but it has no effects.
Could anyone give advise to resolve this issues, i have no ideas anymore.

Thanks in advance.


do a factory reset to 1 GRP2603P phone try to register A TRUNK sip DIRECTLY to understand if the problem persists


Is factory format the factory reset?
If yes, I did it. No result.


no result what does it mean? Did you directly register a sip trunk after a factory reset? The problem persists?

if you are sure the problem persists you can report to Grandstream Support here:



Thanks for your patience.

It takes some time to build an auto-testing environment for reproducing this issue.
We are sure this issue is solved on the latest V1.0.3.72 by testing over 50K+ times without issue.


Please kindly try the V1.0.3.72.




We are testing V1.0.3.72 for 3 days and it seems problem really resolved.