GRP 2613, 2614 and 2615 phones very slow


On multiple new UCM systems including a 6301, and two 6308s at the latest firmware, with GRP 261X phones at firmware we are having very bad response times when - picking up the handset to hearing audio, pressing the speaker button to hearing audio, pressing the menu button to seeing the menu on screen, dialing numbers very slowly updating on the display, and so on. I have tested this on multiple phones in multiple (local, not remote) locations. It seems that the phone goes to “sleep” after a short amount of time and then will respond very slowly. After it has woken up it is faster, but certainly not as fast as my old GRP phone on my UCM 6204. The web interface is also very laggy and many times just opens a blank page until it is reloaded a few times.

Myself and another tech have already opened tickets with Grandstream, so this post is to see if this is a common issue that other users are having. It seems like the firmware upgrade to make the phones unified and to use a new web UI is possibly part of the issue. I have not had this problem with the previous firmware.


try to use a single codec, eliminate all the others,

P8563=0 [Enable Headset Noise Shield]
P8538=0 [Enable Handset Noise Shield 2.0]
P26073=0 [Enable Audio RED with FEC]


Thank you. Paring down the codecs to 1 did not change the issue. I have found the headset and handset noise shield settings in the phones web UI, but not the audio RED with FEC. Can you tell me where to look? I realize I could program them with Pcodes, but I want to change them from the web UI and test first.


I gave you some elements to modify,
you can find everything in the manual or with a search on your phone:


Right. I checked in the manual and the GRP261X series admin guide makes no mention of audio RED with FEC. Thank you for your suggestion.


on the manuals that I gave you in 1 minute I found what I wrote above:

3 2 1


Right. Where in the web UI is the audio RED with FEC setting?


I remind you that this is not Grandstream assistance,
just read above:



I know where I am damiano70, I was just razzing you a little. Thanks, have a great day.


An update to anyone seeing this post because they have slow GRP 2613, 2614 or 2615 phones. The issue is Grandstream’s 1.0.9.x firmware, specifically when running on the 13s, but also to some degree on the 14s and 15s. It will make a 2613 so slow that from when you pick up the handset or press the speaker button up to 5 seconds of silence will happen before you hear dial tone. It will also make pressing buttons on the phone really slow to react.

What I did was downgrade all phones to firmware, and that solved the issues. The catch with downgrading the 2613s is that (I think) they are so slow that when you go to downgrade them they time out and fail about half the time. If the firmware update (downgrade) fails, just immediately do it again and it will eventually work. It can take up to 15 minutes to downgrade, so be ready for that. Downgrading the 2614 and 2615s went much faster.

Any Grandstream rep on here - is anything being done about this issue?


Thanks onthewire, it’s always good to hear feedback from other users. Some people are so cranky on here… I agree the grp series firmware from the beginning is hit or miss. I just upgraded some to to .99 not .103, and they seemed to work better than what ever slow firmware they were on before… and grp are supposed to the best in class…


It seems the GXP2130 through GXP2170 performs much more quickly and reliably than the GRP26xx series. I know up until 2019 the GXP2130+ phones were a bit laggy, but Grandstream shipped fixes to make them perform better.

We’re 3 years in with GRP26xx phones, but the lag issues, core dumps and such persist :c

Using TCP rather than TLS helps on the GRP26xx phones FYI.


Good to hear I am not the only one with these issues.
I worked with the Grandstream devs on obtaining logs, core dumps and even videoing handsets side by side to demonstrate the lag. The devs seem genuinely interested in helping solve the problem but I am beginning to come to the conclusion that possibly software isn’t going to fix it and the hardware itself just isn’t powerful enough as no matter what is tried the lag problems just keep happening.

I have several GRP2613 and a small number of GRP2615 handsets where I am and I find all the GRP2613 handsets have the lag issues whilst the GRP2615 seem rock solid and doesn’t have any such problem - go figure!


Have you tried the solutions listed above?


I have indeed. The codec idea was clever and did somewhat help though but I had already learned of that tip a few months ago from other forum posts. The lag is still very much noticeable however.

It beats me how replacing an old analog phone system that was rock solid and upgrading it to a grandstream system has been a step backwards. If there was some program to trade in all the GRP2613 handsets with GRP2615 handsets I would do it in a heartbeat I reckon.


Above I indicated much more than just the codec


Sorry if I was unclear… Yes I have tried all things above.


Try to disable WebGUI, URI Support + Remote Control Popup Window Support
and see of this will help


I’m starting to get reports of this as well.


Can we get a comment from Grandstream on this issue as its getting worse out there.
Anybody had luck with disabling any P codes like @electr0n suggests.

I will try Beta to see if it helps.