Grandstream UCM won't allow ring time longer than 60 seconds


#1

Hey everyone,

I’ve seen this question posted previously, but never with a solution so I’ll try my luck here.

I have a mixed environment of IP phones, IP Dect cordless phones, WiFi phones and analog phones with gateways. No matter what setting I change, the phones will never ring more than 60 seconds which leads me to believe that it’s a PBX problem.

The default ring time is 22 seconds. This works. When I manually change the ring time on an extension or ring group it extends to 60 seconds and disconnects.


#2

Hi Izzy,

Did you have a look at PBX Settings>general settings>General Preference>Ring Timeout also?

Hope this helps


#3

We have that set to 22 seconds. That’s just the default setting. Anything else I can check?


#4

How is the callflow?
Which Endpoints?
It´s just little information
Where did you check ringtimes until now?
Perhaps it´s on provider side and he cut´s off after 60 sec.
What happens if you register phone directly to provider?


#5

On the gui for the device, go to the account then call settings. Scroll all the way to the bottom and you will see ring timeout set to 60. Just changed for a test and now rings longer.


#6

Don’t think it’s provider related. Having the problem extension to extension internally. I set call timeout on all devices to unlimited. Still getting calls terminated after 60 seconds ringing.


#7

I’ve gone on about this before and have asked for Ring Group’s to return a SIP 200 ok when rung to prevent this.

Time to address this.


#8

I think it might be too hard basket as it might be related to the core of asterisk… unless someone else that is running core asterisk command line can verify…it might be best to set up a no answer solution for the extension or ring group to be answered by an IVR…before proceeding further…

Incoming external calls are reliant upon the providers upstream, only way ive dealt with this issue is to do as ive stated, recommend to the customer that there needs to be an IVR to answer the call at the 18 second mark else the caller is going to hang up.

That’s my take on things…


#9

you set the timeout time in telephones to, for example, 90 seconds? It seems to me that by default they are set to 60.


#10

Threre are 2 places where you should check ring time.

  1. on extensions GUI itsself as zak706 wrote already
  2. in extension settings on UCM
    Therefor in UCM go to:
    Extensions/Trunks>Extensions then edit each extension and check if there´s a value entry in the
    Features >Other Settings>Ring timeout.
    If the extension has VM configured,then the call leads to Voicemail after X seconds.
    If not, then you´ll get a busy signal after the time in seconds of this entry.
  3. If the call ends after X seconds if you call a ringroup or IVR, then you have to check
    the entries in ringgroup or IVR.
    But If this happens also if you call internally from let´s say ext 1000 to 1001 then you should have a
    look just in the first 2 examples.
    Good luck

#11

@damiano70 Changed defaults. Doesn’t help things.


#12

@grandgrand None of these settings are taking affect.

To further complicate things, I randomly had a call that rang for 120 seconds before hanging up. Happened once. I couldn’t replicate it.


#13

120 seconds would be normal if it was an inbound call.
If it only rings and the call isn´t picked up by IVR or else, then 120 sec. is a standard value
when providers disconnect. After 2 minutes waiting and nothing reacts everybody should beleave:
Nobody there or nobody can take the call.
There´s a swabian saying: "A good one (customer) will call again.
I think 120 is also enough. A standard caller in those days let it ring about 35 to 40 secs.
If nothing happens like an IVR or a call queue then most hang up.