Grandstream gxp 2170 locks up

ip-communications

#1

Hey there.

We’ve got a grandstream gxp 2170, with 1.9.25 firmware. I’ve tried the beta firmware, but still get the same strange gui errors (not sure about lock ups). I’ve also tried 1.8 firmware, which is when we started trying to troubleshoot this in house. We switched phones as well, but the problems continued with the new phone so we haven’t swapped away again. The phone is currently hooked up to a 2020EXT extension board.

Basically, transferring a call will occasionally lock up the phone interface, allowing no input. The call is eventually ended due to timeout. Only a power cycle will bring the phone back to life, where it will perform fine for a few days and then lock up again.

Also, I noticed a lot of gui errors as I browsed the config: Under “Upgrade and Provisioning,” the upgrade button is replaced with: {el=firmwareUpgradeBox, rowid=0}
Similarly, the extension board settings are all code like the above, instead of actual values and buttons,and there’s nowhere to change any settings. ex: {el=Mpkrender, source=, rowid=1}

What’s causing this? I’ve tried factory resetting a number of times while flashing different firmware versions but the gui seems permanently messed up.

Is this a hardware problem with multiple phones? Or is something anomalous with our setup?


#2

Crash dump attached.


#3

Make GS ticket, if coredump is generated it is serous firmware/hardware problem.
I doubt anyone can read memory dump here :slight_smile:


#4

I’ve seen this reported a number of times on the forums and Grandstream doesn’t appear to be able to shed any light on the issue.

I have also experience it myself. It happened on one particular customer site, when the phones had “Attended Transfer Mode” set to Dynamic. When the phones were taken off site or were set back to the default “Static” setting - the lockups stopped occurring.

I can’t explain why that was the case, but it might be worth checking that setting.


#5

We are starting to get numerous reports from customers about this phenomenon on all GXP21xx phone models. I also now have two GXP2160’s in the office that this is happening to. No clues yet.


#6

We also experience this all the time. GXP 21xx phones just freezing up.

We haven’t sold a single Grandstream unit in the last year for this reason - hoping newer firmwares would fix it. We’ve now fallen in love with Yealink, because their phones work 100% reliably.


#7

Can you set up syslog and reproduce the issue?


#8

The GUI issue can be fixed by clearing cache on your browser, but the locking up seems like a bug. We can reproduce lockups by having a user on a call, then have another call come in, and the user can press anything except answer or reject and it will freeze. Only way to resolve is remove power then reboot.

This doesn’t happen on most of our phones though. Only a few. But the common thing among them is that they all have more than one extension registered to them


#9

Unfortunately most of our lockups have been on phones with only a single SIP account, so we don’t share that pattern.

We have been able to capture the lockup in Syslog multiple times, but the syslog has no useful info - even GS can’t seem to identify anything wrong.


#10

One of my gxp2170 will lockup when nothing is happening. It only has happened a few times and usually a power cycle resolves it. But usually when it locks up it just gives the date and time as 00/00 and 00:00. Sometimes the BFL will show green but the fields are greyed out.

But like the above there is no pattern to it.


#11

I’m getting the same issue on 2160. Ver 1.0.9.25

Does anyone know if an upgrade to Beta or downgrade resolves?


#12

Upgrading and downgrading do not help, we have tested all the latest versions, and we tracked this issue all the way back to 1.0.7.x versions.

You can actually cause a similar lock-up by accidentally repeating a P-Value in the config file.

Because a repeated P value can cause this issue, it tells us that GS is using an ancient XML interpreter, or they aren’t doing appropriate error handling.