Grandstream GSC3570 Firmware - not re-booting


Firmware version:

Issue with scheduled auto reboot.

Setting the automatic reboot doesn’t actually do anything, no matter what settings are used (other than setting auto reboot to “No”, which works perfectly :wink: ).
When we set automatic reboot to “Yes, reboot daily” (with the time set to two minutes after clicking “Save and Apply”), absolutely nothing happened when the clock reached that time, or after that time. The same applied for “Yes, reboot every week on”, and “Yes, reboot every month on day” (again, both two minutes after applying the change, and the correct day).

The unit was initially set to reboot once a week, however the day after it was meant to have rebooted, the unit had no sound (the main reason for wanting the reboot to work). The unit was then rebooted manually.
A few days later we decided to test the auto reboot, in case it somehow hadn’t set. So we tested the unit by setting it to reboot daily (within ten minutes of current time), which meant the unit was in sleep mode (black screen), but while watching the unit at the time it was set to reboot, nothing happened. Checking the system up-time confirmed that the unit did not reboot. We then tested with a two minute time frame so that the unit wasn’t in sleep mode, just to see if that made any difference, but it didn’t. After every test, the system up-time confirmed that no reboot had taken place. The only way the unit will reboot is by manually rebooting it via the screen, or web interface.

The firmware ( was applied roughly a week ago and the unit was factory reset after applying the firmware. The unit has also been manually rebooted several times during the testing, but still, the auto reboot does nothing.

Anyone else experienced this issue?


Try to upgrade to FW1.0.5.17, which already published.

Could you help to trying following:

  1. Factory reset the GSC3570 and reconfigure it (you can backup then restore the CFG file, or manually configure from scratch again if you have time).
  2. Clear the cache of the browser, and configure it again.
  3. Use another browser (like Firefox, IE if you are using Chrome) to access the webUI and configure it.

Please advise what you get. Thanks.


If using IP Paring also no “Preview”, then you have to configure in the GSC3570, “Settings” --> “External Service”, configure the GDS3710 open door there, you will have “Preview” as well as virtual open door when doorbell pressed.

Please advise. Good Luck!


Thank you for the response.

I am not overly comfortable installing the new firmware at the moment, given that it is currently in Beta, and also can’t be downgraded if something goes wrong. Once it is officially released, I will be a bit more comfortable doing the upgrade.

Normally the Web access to our Grandstream devices is done through MS Edge, as we initially had issues with Chrome and Firefox accessing the live preview on our GDS3710.

We have done another factory reset on the GSC3570, restored it to its previous settings, but auto reboot still didn’t work.

Also, setting up the auto reboot (all options tested) through both Chrome and Firefox made no difference, the auto reboot doesn’t work.

Forgot to mention in the first post, the hardware version of the device is "1.4A".

I guess the best option for now, is to wait until the firmware is officially released.


Yes, upgrade to is the best option. Normally, BETA firmware will move to official after released for 3 ~ 4 weeks and no major complains from field. That is the usual procedures to release firmware. So it is just a waiting game. Thanks.



Unfortunately, even after upgrading the firmware to, the automatic reboot feature does not work. This was tested during each stage of the firmware upgrade, on two different units, with the same result for both.

After creating a backup of the config data, the firmware was updated on the first GSC3570, the automatic reboot feature was tested, but it did not work. Then the unit was factory reset (as we do after every firmware upgrade), and the automatic reboot was re-tested, but still didn’t work. Then the configuration data was imported, and again after testing the automatic reboot, nothing happened. Then the exact same process and testing was done on our second unit, with the exact same result.

No matter what we do, the automatic reboot refuses to actually do anything.

The only way I have managed to get the units to “automatically” reboot (without clicking reboot in the web UI, or on the unit) is by sending a command over SSH with Task Scheduler, however this requires a computer to be running, logged in, and unlocked on the days that it is scheduled to reboot the units (this is due to the SSH terminal needing “user” input to type “reboot” and press enter, the script then locks the PC). This honestly isn’t ideal, as leaving the computer unlocked and unattended for roughly three hours (the scheduled reboot is for a time that we are unlikely to have someone come to the gate) is a little risky. Especially when the automatic reboot functionality is supposed to be in the unit.

I’m not exactly sure what testing you have done on this feature, if you actually got it to work, or if anyone else is having this issue, but it seems odd that two units are unable to automatically reboot, despite the feature being stated as available on the and firmware releases.


What kind of Browser are you using to access the WebUI of GSC3570? I recall someone reported using cell phone browser not working but all working fine if using browsers from PC like Chrome or Firefox, etc.

Please make sure you are NOT using smart phone browser and using computer browser to access webUI to configure the GSC3570, and clear the cache of the browser before you access the webUI.

Thanks and good luck!


Thanks for the response.

I have been using a Windows PC to do all of the setup/configuration, and testing with all of our Grandstream devices. At no point has a smart phone (or tablet) been used with any of the devices (other than the GDS3710 calling through when the doorbell is pressed).

Clearing the cache has not helped with this issue so far, I clear my browser cache during my testing.
As stated in my second post, I use MS Edge to configure the devices, but I also tested the automatic reboot feature with Chrome and Firefox. If it was a cache issue, then it would have worked first time on one of the other browsers.

I have just now tested this further by using a different PC that has never accessed any of the Grandstream devices that we have, I logged in, setting up the automatic reboot, and waited for the time that I set to pass (while standing in front of the GSC3570 unit I was testing), and no reboot happened, which the system up-time on the device confirmed. I did this twice in both MS Edge, and Chrome.

Given that my result is the same with both of our GSC3570 units, it seems unlikely that it is a matter of a dud device, especially as all other settings that I use, or have tested on both devices appear to work. The testing that I have done also shows that it’s not an issue with the browser or PC that is being used to configure the devices.

I am also surprised that there was no provision added to the device to allow the user to set the automatic reboot directly on the device through the “Settings” > “Advanced” section. Fingers crossed this is implemented in the next firmware update. While on this point… the “Setting” button on the UI, should really be “Settings”. The settings page is correctly titled, but the button is missing the “s”.

If anyone else with a GSC3570 reads this, and has the time to quickly test the automatic reboot feature (just a quick set and check, doesn’t have to be to the extent I’ve done), I would really appreciate feedback on your results.


I just tested, this feature seems broken or a bug, will report to the DEV. Thanks for the good catch!


@David_NZ: The DEV advised that Auto Reboot will take effect after reboot when enabled and configured. Could you try manually reboot the GSC3570 then see whether the Auto Reboot taking effect?

Please help to advise. Thanks!


Thank you for checking this with the Devs, and thank you for the help.

I can confirm that manually rebooting the device after setting the automatic reboot, does work.

I must say though, at no point on the automatic reboot config page, does it say that a manual reboot is required, there are three options “Save”, “Save and Apply”, and “Reset”. So I was under the impression that using “Save and Apply” was all that was needed, given that no other features require a reboot to take effect (other than firmware upgrades).

I would suggest that the Devs either add a note to the page stating “Please manually reboot this device after applying your changes.”. Or have the “Save and Apply” button reboot the device after applying the change (adding a note to inform the use that this will reboot the device would also be a good idea, if they added that functionality).


Yes, I agree with you totally. This part is NOT intuitive and user friendly. If reboot is required, then the “Save and Apply” once clicked should be linked to a reboot prompt. Will pass your suggestion to DEV team.

Thank you for using GSC3570.