Grandstream GRP2614 not receiving inbound calls over NAT


#1

I have to say I absolutely love the Grandstream Cloud management portal (GDMS). However I’m running into two issues that refused to resolve.

  1. Background image and screensaver won’t change for the life of me.
    I’m using Account 1 > General Settings > Picture > Select > Upload image

  2. After registering GRP2614 from a home network to a FreePBX server in office (via a router with ALG turned off), inbound calls work… after several hours the inbound calls stop ringing on Grandstream GRP2614, yet outbounding to FreePBX works perfectly (two-way audio and everything). I have had Yealink T46S deskphones working with similar settings for two years now without any problems. And as a note, Asterisk shows the phone is registered on my home IP just fine. (just like it looks for the Yealink’s when they are working)

  • Account 1 > Basic Settings > SIP Registration: YES
  • Account 1 > Basic Settings > Local SIP Port: 5061
  • Account 1 > Basic Settings > SIP Transport: TLS/TCP
  • Account 1 > Network Settings > NAT Traversal: STUN
  • Settings > General Settings > STUN server: stun.l.google.com:19302

Anything else I should be checking?