Grandstream DP750 base station. Power LED flashing only, unit is dead


HI all,

So my base station Grandstream DP750 has decided to die on me after many years of trouble free usage.
The Power LED keeps flashing on/off about one flash per second. All other LED’s are off including the LAN cable activity indication (orange / green LED’s) on the back of unit. None of the LED blink even once at any time.
My handset, Grandstream DP720 gives following message on the screen: “Info Out of range”.

I am unable to access the web interface, as there is no communication between the DP750 and my LAN setup. Internet is however working fine on all other devices both wired and some few wireless.

I tried to power cycle the DP750 but the error remains with blinking Power LED.
I tried the factory reset with a pin holding the button down for at least 7 seconds, error still remains unchanged.
Finally, I did reseat all cables such as LAN cable, Power cable on their respective both ends. Still have error.

What can I do now?
Note I tried to find topics regarding this problem on this forum but to no vain.

Please help.


Perhaps replace the power supply


Thank for the reply, however a damaged power supply, in this case a switching power supply which is original, would result in no LED activity at all.


Well you know best then…

I am offering what I know, which is when the power supplies become weakened from power surges etc and are not able to power the unit fully you will get some lights but not enough to completely power the unit - ergo hinting at replacing the plug pack power source.


and/or, trying PoE if possible, as the circuit is different.

These small switching power supplies are indeed susceptible to getting damaged (mostly heat related to surges) and no longer able to maintain regulation. It may have fallen outside the limits and is unable to meet the parameters of the processor to start-up.


Power PoE is controlled by the hardware, not the software, if you can confirm the power supply is working correct, it means the DP750 is kind of in a reboot loop, it keeps restarting at very early stage that even all other LED haven’t been triggered yet.
I would suggest:

  1. Replace the power supply unit or use PoE for the power to make sure the PSU is working correct.
  2. Try to factory reset the device, you said you have press and hold the pin hole for more than 7 seconds, please try to hold it a little longer, like 30 seconds, if it successfully factory reset, all the LED will flash once at the same time.


And the issue is solved. Changed the power supply from the ordinary power supply to PoE and the DP750 is up and running again.

Many thanks you all!