Getting fax line to use outbound route that uses source caller id matching


#1

I have a fax machine connected to fxs1. I have a POTS connected to FXO1. I create an outbound route in position 2 right after my emergency route, It filters by source caller id to only allow that fxs1 line / extension 6200. So long as I have no other outbound routes it works and routes the fax’s calls through that fxo. If I add a outbound route in position 3 or 5 called local, and use my sip trunks, the fax machine will use those even though its the subsequent outbound rule. Im very confused why this is happening. why it is not following the order of the outbound rule list.


#2

Sounds strange.In my opinion this should work the way you show it here.
Did you try to delete and create the CID filtered outbound route new again, after adding those new outbound routes in the higher positions?
Which UCM Firmware do you use?
Maybe an upgrade fixes the issue. Maybe you have to recreate those outbound rules after the upgrade,too
that it works .But don´t forget to do a backup from the config to your PC before you up or downgrade and have a look at the release notes first.


#3

I think I got the device on 1.0.9 originally, then upgraded to 1.0.11 which I had used for last 4 years and is when I tried setting up fax stuff originally. I then upgraded to 1.0.18.18 when the security issues came out around 2 months ago. I never got the fax stuff to work in the past properly, but I think filter on source caller id is a feature added past 1.0.11 so I figured id try again.

A few of those upgrade steps claim you will have to apply your backup, but ive never seen it require that / and never lost any settings., so I never did. I could just factory reset it and re-setup everything. Its not so bad now that you can download the custom prompts.


#4

Which UCM Version is it?


#5

Pattern > sequence


#6

Only a few things I can think of;

  1. The number dialed on the fax is not meeting the requirement of the dial plan, so it looks for one that does. (This is what Marcin is suggesting as well).
  2. The fax line (FXO) is busy or has an issue that causes the UCM to look for an alternative route (assuming you have one set).
  3. What is being dialed does not meet the provider requirements for the FXO dial string and possibly again a failover.

What you can try is to add a prepended digit to the string and remove the source caller-id and make it have a privilege. Use a “9” for example and prepend that when you dial out, with a strip 1 in the rule. As the 9 will be unique in the string, it will force the FXO to come into play.


#7

I think i found bug in latest soft UCM but could not replicate it.
UCM ignored Privilage Level access and go other route (no reason).
When i changed to source caller ID it start working correctly.

Anyway pattern is most important, sequence matter only when pattern are same (problem above can mess routing) .


#8

this is a ucm6104 on 1.0.18.18

thank you for the suggestions. If I disable all routes but the fax outbound route it uses the pots/fxo line. I assume this means there isn’t a condition like busy line / not dial plan issue. But as soon as I renable the localnew route it goes back to using that.

I have the fxs faxline extension set to international privilege. I don’t know if this could be the issue, I guess I could change it to local for testing. Not that it really matters since the fax outbound route will have the pots/fxs line as the first trunk and then the voip as failover trunks when im done (I disabled that for testing now, to simplify) and there is no privilege level necessary to use a source caller id matched outbound route I assume.

Similar to the “prepend” then strip work around, I assume I could also just set the fax machine/fxs to internal only, that way it was not allowed to use the local route, I was trying to figure out why it didn’t work though before resulting to that. I am sure I have many other fax related settings wrong, though it generally works, even though it has been sending them over the sip trunk (Nextiva) it tends to be successful maybe 60-70% of time.


#9

in regards to pattern > sequence. My patterns are visible above in the picture. Obviously in the US I need both the phones and the fax machine to dial standard use numbers 1-800-888-8888. with or without the 1 and with our without the area code. Cant really make them mutually exclusive except by adding a 9 or something then stripping it.


#10

Hi,
Why don´t you just set the outbound route pattern to
_X.
_+X.
and then activate "Enable Filter on Source Caller ID"limiting to the FXS Fax extension bound to the analog Main Trunk you want to use?