Getting error msg on forward calls " all circuits are busy now please try again later "


#1

Hi. I recently got the UCM 6202 with the GXP2170 phone.
I have set up everything (Updated Firmware, Analog Trunks, Inbound and Outbound rules, extensions)
I have also changed both the phone and the PBX device to static IP.

I can receive calls and make calls without any problem. However, I like to activate the option of forward if no answer to forward the calls to my mobile number as I work outside the office most of the time doing site visits at construction sites.

When I activate the forward calls (all types, busy, unconditional and if no reply) it keeps giving me an error message saying " all circuits are busy now please try again later "

Sometimes it just cuts the phone. The forward never actually happens.

I can make a call to my mobile number from the phone without any problem. However, when I put the same number to forward the calls to, it doesn’t work.

I am using a normal analog line from the telecom provider in Dubai (Etisalat) the and its connected to port FXS 1. when I connect to FXO port, the phone stops working completely and there is no dial tone.

This is a make it or break it feature for me.
I’m hoping someone can help me with this.

Many Thanks


#2

Can you hook up an analog telephone handset and make and take calls using your analog line?
How many analog lines do you have and is there any other type of telephony service in use besides the analog line?


#3

You will need at least 2 circuits (2 analogue lines, 1 analogue and 1 SIP, etc.) for this to work. The inbound call needs 1 circuit and the outbound a second.


#4

Hi Mr. Behrooz,

I’m just curious about your statement on your post. You have said: “I am using a normal analog line from the telecom provider in Dubai (Etisalat) the and its connected to port FXS 1. when I connect to FXO port, the phone stops working completely and there is no dial tone”. I assume that there is no connection on fxo port (please correct me if I am wrong). If my assumption is right, then how did you made an analog trunk? I’m sorry if I’m out of context…:pray: :pray:

Best regards,

Ray


#5

Hi, I did hook up the old telephone and used it… works fine… Also I can make phone calls with the IP Phone… I also made mistake above… My both lines are connected to FSX 1 & FSX 2 ports… I only get 2 analogue lines…


#6

Hi,
Sorry my bad… I made a mistake… I connected both my lines to FXO 1 & FXO 2.


#7

Hi,

Thanks for the tip… I do have 2 Lines… each connected to FSO ports… above I mentioned FSX by mistake…

Basically what I want to do is the below scenario :

When customer call either of the 2 lines … They get a welcome message saying… Thank you for contacting us somebody will be with your shortly… meanwhile the customer listens to this… the first Extension (1000) starts ringing for 10 Second… If no reply, then it forwards the call to my mobile number…

For the first part… I added a ring group and I changed the inbound rules to go through the ring group and listen to the call on hold tone that I have uploaded… this acts as my greeting message to the customer… then the phone on extension 1000 rings without any problem… .on that Extension I have activated all types of forwards… forward unconditional. Forward if busy… forward if no reply… non of them work…

I have also added another extension (1003) and make that extension to forward unconditional… and I have forward if no reply of my Extension 1000 to do an internal transfer to 1003 and that one forwards it to my phone… but its not working…

its very frustrating… i feel like im stupid… there is something that im not doing right


#8

Not stupid, we just need to know more about the setup which was missing from your post.

When you set the forward, it appears that you set this in the UCM, although it is possible to do so in the phone as well if the call features are enabled in the phone. I disable the phone call features when connected to the UCM as I want the UCM to control the calling. Enabling in the phone is useful if the phone is connected directly to a provider where the provider is a SIP trunk provider and not offering PBX like features such as might be available with a hosted provider. I suggest you disable the call feature function in the phone and let the UCM handle.

The call forward at the extension level from within the UCM is a system call as the system is handling the forward, not the phone itself. The outbound rule is usually the stumbling block either because the rules have source callerID enabled or the privilege level is too high. The system does not have a source callerID and the privilege level is Internal.

To get around the issue;

  1. In the call forward area of the extension, input the number in the appropriate status condition for when the system should forward, but prefix the number to be dialed with an additional number, say a “9”. So, if the desire is to dial 999888777666, you would input 9999888777666. The added 9 will make the rule appear unique from the standard numbers being dialed.
  2. Create a new outbound rule and in the dial string area add the 9999888777666 number and set the privilege level to internal. Set the outbound trunk to whichever line you wish and then set the failover to the other PSTN line.
  3. In the same outbound rule indicate strip 1. This will remove the added 9 before dialing out. If you are already using the 9 (and other numbers) as a prefix, then select a unique number or numbers and just strip the needed number of digits from same so that the prefix is not sent to the provider.
  4. To be safe, put this new rule at the top of the rule list.

Adding the prefix using a unique number will cause the system to not use the other rules that likely have a higher privilege level than Internal.

Try the above and see.


#9

Thanks man. I followed your method and it fixed it…exactly what I needed… Many thanks.

Im gonna write it here so if someone in future faces this problem can search and find the soluton.

  1. The second line (the line that actually makes the forwarded call) shall be on top of the sequence list on the outbound rules.
  2. The outbound rule forces your phone to make all the outbound calls form the 2nd line… While probably your first line is the primary number that you want to use… for that to work you need to add an extra digit to the outbound rules of your first line (primary Trunk that you like to use) and add 1 digit for strip. This way the phone will use the outbound rule from the primary line eventhough the outbound rule might be 3rd sequence on the outbound rules list.

This way both the call forward function will be solved and you will not get the all the circuits are busy notice and also you get to still make phone calls with your FXO 1 (primary number) landline.