GDS3710 PIN Alarm



I have a problem with “Alarm for PIN Input Error” . I enabled him but when I enter 5 bad PIN codes it doesn’t work.

My firmware version is


Does it firmware bug?

Thanks for every advice


I tested latest firmware and seems working (check out: Once question, have you configured the “alarm profile” after you checked and enabled the feature?

You have to configure the “Alarm Action Profile” before it will start to work, default the profile is empty therefore no action will be performed.

Also, if you only like me to active siren, the length is controlled in the “Alarm Events Config ==> Digit Output ==> Alarm Output Durations(s)”, default is 5 seconds, which means the siren will sound about 5 seconds (not exactly but roughly as internal clocking is different with real 24 hour time clock but close) before automatically stopped. You can adjust the timer to meet your environment and application scene.

Please advise whether this works for you after active the alarm profile.

Thank you very much for using Grandstream Access Control products.


This is my configuration:

I tried PIN codes with schema PIN_CODE# because I have Disable Keypad SIP Number Dialing


Yes, normal SIP dialing with private PIN input, this is working. But if you “Disable Keypad SIP Number Dialing” and let the GDS just to input PIN (w/o #), this feature is NOT working or not implemented.

Will pass your feedback to DEV team and will add this feature in next firmware cycle.

Appreciate the feedback and thank you for using Grandstream Access Control Products.