GDS3710 Number Called When Door Bell Pressed not calling all numbers


Hello All,

I’ve got a GDS3710 V1.5A upgraded to

I’ve many issues actually with it and our FreePBX with the new firmware ( one way audio ), but the issue here is that I’m having it call SIP phones directly for the door function, to get the ‘video’ to show on our GXP2160’s.

It works, but the issue I’m having is that its not ringing ALL the phones on the list "Number Called When Door Bell Pressed’

I’ve got it set to Parallel Hunting, and I’ve comma separated out all the IP addresses.

for example, here’s a sanitized copy of my list:


it will ring 101, 102, 103 and 131, but not 120. I can confirm if i use the 'dial number ’ function on the door management webpage, I can call each of the x.x.x.x numbers without issue, and ‘video’ works.

Am i missing something? I once got an error message stating a maximum of 10 numbers can be called, but at this point, i’ve only got 5 total numbers in the list, and it still won’t go beyond the first 4.



Are you using “direct IP call” and let GDS call peering IP addresses without any IPPBX/UCM involved, correct?

This has some issue and pulled back. Please wait for the next firmware.

What is the previous version you upgraded from? Please try to factory reset the unit from WebUI (save all the settings before you do this), and reconfigure again to see whether the issue gone.

Please advise the result and wait for the new firmware if issue still there. Sorry for the inconvenience caused. Thank you for using GDS series products.


Also, what network segment you are configure them? /24 or VLAN or some special settings? There is a bug in the special network setting. If you change to standard segment, will the device ringing all IPs?

Please advise. Thanks!


the phones and the door control are all on the same network segment, x.x.x.1 - x.x.x.254

same gateway, netmask, even dns

i am using direct call to get it to work, yes. that works for 2 way audio.

I went from version 1 firmware directly to, following the procedure to do so. i backed up my settings, but did a factory reset and manually redid the settings .

I wasn’t on 1.0.3.x at any time


@michaelb : So you are upgrade from 1.0.1.xx to directly, and already perform factory reset after upgrade, and reconfigured the GDS, correct?

For direct IP call to multiple IP addresses, the should work in either parallel or serial hunting. Could you try changing to Serial Hunting to see it rings all the IP addresses in sequence? Then change back to Parallel to see whether all the IPs ringing at the same time? If it rings all the IPs, you pick up any of the ringing phone, you should be able to get media (audio if it is audio phone and video if video phone, or MJPEG frame if GXP21xx) in the phone you picked up and press the PIN (or soft key if you programmed already) to open door.

I tested and the works for me for the two IP addresses I inputted in the doorbell call field of GDS.

Please advise. Thanks!


yes, that’s how i updated. we bought it about 18 months ago and never did any updates until

i have no issues with the audio or video with direct IP, or the door open PIN working, just not ringing all the phones.

I’ll test switching to serial hunting and back to parallel. is there any crazy reason like the IP’s are not in ascending order? ( x.x.x.131, x.x.x.120 )


Am i able to downgrade to


Quick question are you using direct ip call or SIP calls?


I’ve been using both, but not at the same time.

Currently, it’s registered as a SIP device, but I’m making my calls from the doorbell directly to a list of IP’s


Did you get video working sip call to GXP2160 with freepbx?


not yet, i’m still looking at downgrading from 4 to 3 and seeing if that helps


Downgrade from 4 to 3 in not available unfortunately. Please contract Grandstream technical support and send out SYSLOG or wireshark trace if possible. Support will take a look to see what might be the issue. Thanks!


You can try to adding this IP to card manager.
Then switch Call Mode from SIP number to Virtual number and add shorten (from card manager) number. It can be problem with length of field. Worth test i think :smiley:


Try upgrade to and trying again.


OK, i’ll check it out now