GDS3710 Impossible Upgrade


#1

Hi! I’ve been trying for three days to upgrade a GDS3710 from 1.0.4.5 to 1.0.4.9. I’ve tried multiple times with different local servers and remotely from GS servers. I’ve also tried to upgrade directly to 1.0.5.2 with no success. The GDS behaves the same way everytime: after reboot, it starts downloading the resources (blue led blinking), after that, the whole keypad illuminates blue twice, then fixed blue led and finally whole keypad white flash and suddenly restarts (sometimes opening the doors!). This process repeats infinitely. It continues to request the resources to the server on each cycle (resources are transferred successfully as seen in the server logs). I’m stuck on 1.0.4.5. The unit works perfectly, the only problem is that it won’t upgrade! I’m loosing my mind with this. (My case is being followed by ticket from Latin America, but nothing had work so far, so I ask publicly (I’m in Italy temporarily)). Thank you very much!


#2

Please try the multiple file firmware which good for old firmware files. I am guessing maybe your units some files stays old even if it success upgraded to 1.0.4.5. (maybe only the main program file but others stays in old file).
http://firmware.grandstream.com/Release_GDS3710_1.0.5.2_for_GDS3710_v1_0_2_x_or_lower.zip
http://www.grandstream.com/support/firmware/gds3710-official-firmware

Please try factory reset the unit, then upgrade to 1.0.5.2 again.

Please advise whether this helps. Good luck!


#3

@ernestostifano

Here is my GDS3710 STATUS Page, please show the information on your device:

Product Model: GDS3710
Hardware Version: V1.3B
Part Number: 9650001413B
Kernel Version: 1.0.5.2
RootFS Version: 1.0.5.2
Prog Version: 1.0.5.2

Thanks!


#4

Hi! Thank you for your answer, I will immediately try your first suggestion, even if the unit is new and was shipped with 1.0.4.5 firmware installed. I managed to save the debug logs during one of the many tests I did, I uploaded it HERE

Please consider the following while analysing the logs:

  • The test starts at the 20:24:23 instant while logging in to set the upgrade path which was: 173.254.235.113/hm/GDS3710/1.0.4.9/Release_GDS3710_1.0.4.9
  • Three reboots happened before I stopped the test to keep the log as short as possible:
  1. At 20:25:57, after setting the upgrade path, triggered by me to begin the upgrade process.
  2. At 20:28:16, self-reboot during upgrade process (end of first cycle).
  3. At 20:30:32, self-reboot during upgrade process (end of second cycle).
  • If I wouldn’t have stopped the process, this cycle would have continued to repeat indefinitely.

Additional Info:

Product Model: GDS3710
Hardware Version: V1.7A
Part Number: 9650001417A
Kernel Version: 1.0.4.5
RootFS Version: 1.0.4.5
Prog Version: 1.0.4.5

I’ll let you know after trying the multiple files firmware upgrade.


#5

Hi again! Multiple files firmware upgrade tentative failed because GDS3710 looks for the ‘gds37xx_fw.bin’ file which is not present in the multiple files firmware.


#6

In that case, it is asking for single file firmware. Please factory reset the unit, then upgrade using the single file firmware. As said before, please upload the screenshot of your STATUS page. Thanks.


#7

OK, I see previous post. You have latest firmware and already in 1.0.4.5. Please try factory reset the device and then continue upgrade using simple firmware file firmware and advise what you get.
Here is the firmware:
http://firmware.grandstream.com/Release_GDS3710_1.0.5.2.zip

Thanks!


#8

Could you advise MAC address of this unit? Looks like there is a internal flash segmentation error in your unit. Please contact Grandstream Support to RMA this device.

Sorry for the inconvenience caused. Thank you for using Grandstream GDS3710.


#9

i think i have seam issue see my topic


#10

Please contact Grandstream Support, and provide remote access to the device. They will help to troubleshooting and confirm the issue before issuing RMA. Thanks.


#11

Hi, Grandstream Dev Team confirmed your hypothesis and have already authorised RMA which I’ve already requested to the provider. In any case, the MAC address is: 00:0b:82:d5:2f:d5. Thank you very much for your help!