GDS3710 firmware update


#1

I have been trying to upgrade the firmware of my unit, but it does not work.
Actual fw version is 1.0.2.9 and I am trying to upgrade to 1.0.5.2.
HW version is V1.5A.

I am using your GSUpgradeTool and files from Release_GDS3710_1.0.5.2_for_GDS3710_v1_0_2_x_or_lower.

I always get the following message:

04/18/2019-14:45:33 - Device upgrade and reboot in progress. It may take some time (about 2 minutes). Please be patient and do not shutdown the program.

After several minutes nothing is happening and no indication of data up/dn is shown, always 0 B/s.

Any hint?

Thanks.


#2

@Ecouto: Try factory reset your device when at 1.0.29, then use local HTTP or TFTP server to upgrade, make sure you are using the multiple file binary firmware because your unit is very old firmware.

Also, try using Putty (SSH) into the unit, and use command line to issue upgrade, you will see all the process dumps during the upgrade process. Save the logs and upload here if it is still not working.

Please advise your result. Good luck!


#3

I have tried SSH into the unit, but the “upgrade” command does not work.
Can you advise how to correctly “upgrade” via SSH?

Thanks.


#4

@ECouto: Once you SSH into the device, please type “help”, you will see all the available CLI command. Go to the webUI of the GDS3710 to configure correct firmware server path and choose correct upgrade method (either TFTP or HTTP), then back to the CLI command line just issue “upgrade”, the device should start upgrade process. Make sure you are use multiple bin files firmware.

If you still have issue, please open a ticket with Grandstream Support and ask for a remote desktop access like teamviewer help. Thanks and good luck!