GDS3710, Fanvil x7, No video


Hi Everyone!

I’ve been through the the GS and 3CX forums and have seen plenty of topics with the same or similar issue as to mine. I feel like I have tried all the of the remedies listed but nothing seems to work. If anyone else has had a similar issue and got it work you help would be greatly appreciated…

Current setup:
(2) GDS 3710 door phones
Unifi 48 Pro PoE switch, all voip traffic is segregated to its own vlan
3cx self hosted on Azure Windows VM with local SBC

Voice calling works perfectly fine. We cannot, however, get video to stream from the GDS units to our Fanvil x7 phones during calls. I can get the video to stream to the browser-based 3CX web client.
I have tried changing the stream values to those listed in this posting where they were able to get things working but have seen no changes.

Since I can stream the video through the 3CX web client I’m assuming that it is an internal network issue or possibly even a setting on the Fanvil phone?

Again, any help would be greatly appreciated!



You might need to contact Fanvil support, if the 3CX web client can see the video, meaning the GDS is sending media stream to 3CX client and it can decoding it (compatible to H.264 standard). It is very likely the Fanvil cannot decode the H.264 media stream from GDS3710. In that case, the ball in on Fanvil side because other vendor can decode and see video normally.

You can also get Grandstream GSC3570, then no such problem will ever exist in the beginning.