GDS3710 DTMF not working


#1

Unable to make DTMF door opening !


#2

Sorry, but not enough info.

We understand that by pushing a key on some device is not causing the other device to allow the door to be opened, what we have no clue about is your setup and devices being used other than the GDS and if the DTMF tones are set correctly between the devices that generate and receive same.


#3

Thank you so much for your reply.
In fact there is no problem. The fact is that DTMF only works from GDS to another device (when somebody push the call button, the device wich answers can send a DTMF code to open the door).
But on the other side (if a device calls the GDS, typing a DTMF code has no effect).
You could perhaps implant that functionality in a further firmware update ?
It can be useful to call the GDS and open the door without the nedd to first call from the GDS.
Best Regards.

Yves


#4

Thanks for the explanation.
On the surface it occurs to me that this could pose a security problem. There would need to be a filter of some type by which the calling extension has the authority/privilege to contact the GDS; otherwise anyone could open the door at any time.

I think if this could be done, then I (personally) do not see an issue with it. You might submit this as a suggestion.


#5

You are right regardons security. But for non professional it is not an issue. Can be a choice


#6

Did you allow this in Basic settings ?
image


#7

Thank you Marcin. Problem is now solved. Check my previous message.
Reagrds.

Yves


#8

Hi Marcin, can you help me.
Same problem than ybourdon.
When GDS3710 calls a another device, I can open the door with the remote Pin.
But when the same device calls GDS3710, the remote pin has no effect.


DTMF Open Door Enable
Hardware version 1.6
Kernel version 1.0.3.35


#9

Hi Pascal.
In fact the oneway DTMF control is not an issue.
I agree with you, this functionality is useful, and it would be nice if Grandstream could add this feature in the next firmware (for exemple : DTMF 2 ways y or n).
I don’t know how to claim for this feature.

Regards.

Yves


#10

Add IP/number to white list.
Sip settings -> Whitest.


#11

Hi MARCIN,

I activated the function White list Number
I add 3 cell phones on the white list and also the phone number of my compagnie.


When the cell phones call the company and do the extension of the GDS, everything works.
When I call my own company ( outbound call from my compagny to my compagny) with a desk phone and do extension number of the GDS, everything works.
But when a device tries to contact the GDS directly internally, it does not work.
I tried indicating only my extension number (223), only the ip address of my workstation (10.0.10.100) and also with the port (10.0.10.100:5060), but still nothing I am blocked .

Of course, if I disable the White list number function, the extension (223) is able to join the extension of the GDS without problem but not able to open the door

The Local SIP port is 5060

According to you, is my error in my syntax or elsewhere?
Thank you


#12

DTMF is set correctly on phone ?
It is hard to say without logs. Try running syslog in GDS and share 1 call.


#13

@ybourdon:

If GDS is callee and you are calling from other extension or number to get into GDS to open the door, those caller has to be in WHITE LIST otherwise will not be able to use DTMF to open door.

If GDS is caller then no such limitation.

This has bee mentioned in the latest User Manual. Please check out.

This security rules is implemented to prevent spam calls or hacked calls to call into GDS to open the door.

Please upgrade your GDS to latest firmware version 1.0.5.2. Please advise whether this helps.

Thank you for using GDS3710.