GDS3710 Camera and Remote Unlock Issues


#1

I recently installed a GDS3710 in our system with a UCM6204 and GXP2170’s. I hooked it up on a desk, updated to the 1.0.7.8 firmware, tested it out and it seemed to be working alright. In the webui, I could see the live feed from the camera and I configured one of the GXP2170’s to remote open the door when the remote PIN was set.

I installed the 3170 on the side of our building and hooked up the electric strike and tested the remote unlock. Everything appeared to be working but when I would call the 3170, the camera display on the screen was all white. Almost like the camera was saturated but it was a cloudy day. If I go to the CMOS settings, set it to WDR, then go back to the live view, it works. If I again go to CMOS set it to Normal, then go back to live view, it looks as it should. This seems to happen randomly and every time I view it after a reboot.

I also added the P32000-P32004 codes in our GXP2170 template with the remote pin to open the door. However, I get a “GDS Action: OpenDoor failed. (403: Authorize Failed)” error on all but one of the phones. I removed the values from the template and logged into a random phone manually and set them and still got the same error. I know the remote PIN is correct because when I change it, it says “No change needs to apply” so it must be set correctly.

The Maintenance > Event Log is always blank so I assume that is just for card access and I’ve not tried to setup any cards. I also setup a syslog server but didn’t dive into the logs too far yet.

Finally, I had the system hooked up and overnight, I had 50 missed calls from it at random times. I know this could be ghost calls but it might be hardware related as sometimes I can tap the side of the unit and it acts like I pressed the door bell.

I upgraded the firmware to 1.0.7.14 just to see if anything was fixed and it is all the same issues as above.

Any help would be greatly appreciated!


#2

Sounds definitely like a loose wire causing a fault for the door to just go off and call without someone pressing the button. Perhaps the Doorbell button has been damaged or did you put something over the metal parts of the unit?

Take a picture of the camera mounted showing the door bell button - because if the 3710 didnt do it on the bench, then perhaps the installation of it has caused the issue.


#3

I’ve had a similar issue - I’ve been using the GDS3710 with GXP2170 and GXP2135 phones and now I am consistently getting the GDS Action: OpenDoor failed error from many of the phones. It worked flawlessly until very recently. So, following this thread.


#4

Could you help to advise

  1. The screenshot of the “System Settings -> Access Setting”, the “Enable Anonymouse LiveView” checked and enabled? How about the settings of “MJPEG Authntication Mode”, etc.?
  2. Does the same issue happen when downgrade to 1.0.7.8 firmware?
  3. For the 3170 ghost call, have you enabled the related SIP settings in the 3170 to reject the ghost call?

Please file a ticket in the HELPDESK and upload the syslog or trace if you have one.

Thank you for using GDS3170.


#5

I’m fairly certain that the installation is not causing an issue nor is the unit physically damaged. I’ll downgrade back to 1.0.7.8 and grab a full syslog over a day to see what I can find. The ghost calls are random so it is hard to predict.

I’ll also open a ticket with Grandstream and then reply to this thread with what I find out.

Thank you.


#6

If UCM involved, could you help to make sure UCM is using the latest firmware? Or you can configure IP Peering or Direct IP call to see if it is working, to rule out UCM issue.


#7

Enable Anonymous LiveView is disabled.
MJPEG Authentication Mode is Challenge+Response.
Issue is present in both 1.0.7.8 and 1.0.7.14. Since I’ve started this thread 1.0.7.14 has been promoted to stable so I’m just leaving it on that version.

SIP settings are left default from factory defaults and then provisioned from UCM. I’m not seeing any reject ghost call options. Can you elaborate?

The unit is hooked to a UCM6204 running the latest version, 1.0.20.23. The UCM is in production so I’m unable to try the Direct IP call.

I’m still confused as to why some GXP2170’s give authentication failure with the correct password. So far I have been unable to capture the issue with a trace or Syslog but I’ll keep trying.

Anyone else have any luck tracing the 403 authentication error on the GXP’s?


#8

@k2211721: It might be some configuration problem. Please send me your GDS CFG file and screenshots of GXP phone configuration pages so I can take a look.

My email: jhuang@grandstream.com

Thanks.


#9

So I factory reset the 3710, then provisioned it from the UCM zero config. Then I logged in and set the remote PIN, and disabled keypad and disable extension dial.
I also added the GDS external service entries to my GXP2170 template and provisioned my targeted phones.

If I call from the 3710 webui to a phone extension, the phone can press open door and it will work. If I press the doorbell button on the 3710 to ring the extension/ring group, it will also work. So it seems to be working now.

However, if I call the 3710’s extension from my phone and press open door, I will get a 403 error. Is this by design?


#10

Good to hear it is working now!

Yes, this is per design and expected, and it is a security feature. GDS as Caller, the callee extension will have no problem to open door using DTMF or “one button open door” (external service if configured); but GDS as callee, unless it is in whitelist, or the extensions are in the Card Management Database (associated with valid RFID card number), the GDS will NOT open door and give out 403, to prevent hacking call or ghost call to trying and testing the open door PIN via SIP remote call.

So configure the Caller extensions into white list, or associate them with valid RFID card in Card Management, then it will work.

Hope this helps. Thank you for using GDS3710!