FXS ATA server registration failure due to Domain with underscore


#1

Hi folks,

We are having an issue with registering FXS 24/48 port ATA’s to our SIP server which appears to be an issue with their FQDN having an underscore. (ex. bobs_pbx.example.com) Has anyone else run into this issue and is there any way around this? Our customer’s PBX has several hundred extensions/endpoints and rebuilding their domain without an underscore is not an option. We are able to register to any other FQDN without an underscore and we are not able to replicate the issue on a different device from another manufacturer. Any help or suggestions are greatly appreciated. Thank you kindly.


#2

Unfortunately, the underscrore in a hostname (bobs_pbx) is not valid for use as a hostname in an Internet name.


#3

Thanks for the prompt reply Ipneblett. Any idea why no registration issues on a different device from another manufacturer? (I would provide the Make/Model but wasn’t sure if against forum rules) One would think if that were true in terms of registering a SIP device that it would fail to register across the board. Thanks for your input.


#4

Hard to say without the details. It is not against forum rules. Have you tried to simply ping the FQDN to see if it resolves?


#5

We were able to register a Yeastar FXS 48 port ATA (new product) to the SIP server and all lines work without issue. Tried pinging FQDN and no reply.


#6

I am confused. Is the SIP server local to the gateway? Are all the devices that connect to the SIP server local?
Is the FQDN an Internet hostname or a local hostname? Is the FQDN supporting a static IP or dynamic?

I do not think Yeastar make a 48 as I think the largest is 32.


#7

No sir, we are a VoIP reseller and our provider’s SIP server is located at their datacenter. I’m not sure what you mean by are all the devices that connect to the SIP server local? All of their phones and the Yeastar ATA (you are correct it is 32 ports my mistake was a typo) are all configured at our customers’ site on the LAN. Regarding the FQDN, we do not host the domain so I am not sure if it is a static or dynamic IP. I appreciate your feedback but looks like we will have to just stick with the Yeastar ATA since there is no way around the underscore issue with Grandstreams. Thanks Ipneblett.


#8

What you can do is in a windows command prompt type nslookup and the domain name - that will give you the IP address of the domain to enter into the sip registration address and the work around for grandstream ata’s until the firmware is rectified.


#9

Thanks for the reply, scottsip. I did try your suggestion but just says “non-existent domain” and got the same result when looking up any of our other customers’ domain. Must not be a FQDN as all of the domains are just customers PBX “domain” name.


#10

Please pm me a FQDN and I will try using my DNS servers


#11

Kev - changing the F/W will not fix the issue. An uderscore is not allowed in the Internet hostname field so DNS servers, not accepting same, cannot resolve same. You can use it in a domain name and presumably you could use it even in a local hostname, but not as an Internet hostname.

Try inputting bobs-pbx.example.com into the external hostname field of a UCM and they try inserting bobs_pbx.example.com.

What I am struggling with is how the Yeastar resolved the IP if all else is equal with how the GS was set with regard to DNS servers. I am pretty certain that the GS gateways will allow an underscore in the hostname as well. So, I am confused as to why it seems that the YS can resolve, but the GS cannot nor does it appear that a simple ping to the fqdn will either.

Any ideas?


#12

Only way might be if there is a local DNS server changing that particular name into a usable External IP


#13

It also would be great to know which provider it is whether it is a private dns / hostname combination that is allowing the registration… maybe Tom might be able to inform us more…


#14

Yes, but then why I stated all else equal.


#15

Thanks for your input folks. The provider is SkySwitch and I would presume it is a private dns / hostname.


#16

After checking with our provider the domain names do not resolve to an IP address and only the domain name as it reads can be used. Thanks. Hopefully Grandstream releases a new firmware that patches the issue with domains having an underscore because there appears to be only 3 manufacturers that sell FXS ATA’s and the Yeastar we are using has already had Web GUI issues and randomly de-registers ports. We would much prefer to use Grandstream ATA’s as we have had very minimal issues. Obviously, I will be sure to avoid any special characters when creating a domain to prevent this issue entirely. Thanks for everyone’s input!


#17

Hi Mr. Tom,

I think what was said by Mr. Larry (ipneblett) was absolutely right before. Please read this link : https://www.digicert.com/ssl-support/underscores-not-allowed-in-fqdns.htm

And maybe you can ask your provider about this and they can help you


#18

Let’s be clear, you used the example -
bobs_pbx.example.com

The hostname is - bobs_pbx
The domain name is - example
The ending - .com - is the top level domain just as are .net .org, .us, etc.

Collectively when put together they are a fully qualified domain name. However due to the underscore being in the hostname section, it is not acceptable as an Internet hostname. Meaning that internet based DNS servers will not accept the name nor resolve it. You can use an underscore in the domain name and elsewhere, but not the Internet hostname so, there is no firmware to fix. The RFC governing the standards are pretty specific.

This statement is somewhat telling - do not resolve to an IP address and only the domain name as it reads can be used". Is there a proxy? I am assuming that there must be an A record somewhere.

Only 3 makes of FXS? No, there are plenty that make FXS gateways - Grandstream, Yeastar, Patton, Xorcom, Dinstar, Sangoma, Matrix, AudioCodes, Quintum, Mediatrix, and others.


#19

Skyswitch is obviously doing this on purpose. I do not think they are the ones who suggested a hostname using an underscrore, but rather that someone made it up not knowing and that Skyswitch utilizes a mechanism where the FQDN is not resolvable so as to heighten security. What they do has my curiosity piqued as when I set up a dummy trunk as an approved provider in 3CX, the system responds back with a see SkySwitch documentation.


#20

Larry,

I do understand what comprises a FQDN. As I previously mentioned we created the PBX domain name (hostname only, the rest is auto-filled by SkySwitch after creating the hostname) with an underscore not knowing the impact it would have when manually provisioning (BYOD) devices. We are WELL AWARE that an underscore can cause issues and we will not be repeating that mistake as it was a misunderstanding to avoid this issue we’re facing entirely. I did not personally create the hostname and we cannot create a new PBX domain and migrate them as they are a very large customer with over 200 analog phones for all of the residential rooms in the building. How SkySwitch handles resolving the domains is a moot point and non of our concern as they handle that on the back-end. I’ve confirmed with their VP of Support that only the PBX domain as it reads can be used an not an IP address on THEIR platform. Regardless of whether you agree with that statement is irrelevant as I am just relaying what I was told. I think we’re diverting the original question as to why the Grandstream DOES NOT allow for a domain name (in this case - the hostname) to have an underscore, yet the Yeastar has no issue when provisioning the credentials and registers without issue using the domain with the underscore.

You mentioned there are many FXS ATA manufacturers, however, our vendor only suggested three (Grandstream, Yeastar and Patton) for pricing reasons and that is the only manufacturers they deal currently with for their own reasons. (we are replacing the customers ATA’s out of good faith as they have had a lot of issues with their Cisco 8-port ATA’s - even though it was installed by their previous provider) I do not make the purchasing decisions as I am just in Support. I figured I would open a forum discussion for my own understanding as to why the Grandstream ATA we tried configuring with the underscore failed but the Yeastar registered no problem. I appreciate all the feedback and follow up all.