Follow me not work to reach external number


#1

Hi , I’m a new member
I’m having trouble with transfer to external number:

  • When I config forwarding on Grandstream phone : It’s transferred to external number when i call from another extension , but not work when i called from external number.

  • When i config follow me on UCM6510 : can not transfer to external number at all (only can reach internal number )

My target : when someone using external phone to call my extension , it will forward to my external phone .
Could some one help me to fixed this ?


#2

99% is an incorrect configuration of the trunk voip


#3

How are the outbound rules configured? Are you using source caller ID?


#4

Hi Ipneblett
Thanks for your consider. I’m using Sip Trunk and Enable Filter on Source Caller ID.
When follow me transfer to my external number, which outbound route will be used ?
Route for my ext or route for caller ext ?


#5

Set up a new outbound route that does not use source caller ID and make sure it is at the bottom of the list and then try. The issue is that the system is being asked to do the forward and as a result, it does not have a source caller ID on its own, nor can you assign it own, and as a result there is no available path for it to follow.


#6

Hey Larry, it sounds like the problem I had when we tried this. I ended up going away from Source Caller ID to make it work. But that was quite awhile ago.


#7

After disable source caller ID, can reach my external number when received call from an internal ext. But from external still cannot.


#8

And is follow me the method that is being used for both internal and external callers? How does an external caller reach your extension - DID, ring group, call queue, etc.?


#9

My extension is using DID and not in ring group, call queue .What should I do with out/inbound with DID ? i’m having over 40 DID trunk.
Example: My Ext: 2002 - configured follow me.
When Ext: 2001 ( DID : xxx_xxx) call to Ext:2002 ( DiD: YYY_YYY ) follow me will forward to my external phone and on my external phone will display DID of 2001 ( xxx_xxx ) . it mean follow me using outbound route of caller , Is that right ?


#10

How many call paths will the SIP trunk provider allow?

When internal you are not using but the SIP trunk out.
With external, you are using the SIP trunk in and SIP trunk out. Perhaps you only have the one call path? Can your system take more than one call at a time? I assume so with 40DID. Post a screen shot of the outbound rules. It could be that it is still following the source caller ID and we may need to see what we can do to alter.


#11

my system can support 30 call In/Out at the same time. bellow is outbound setting for my ext DID :


#12

The rule is wrong, permissions must be “international”.


#13

Why must it be international?


#14

if you leave “national” it doesn’t give you all the figures composed


#15

Nope, sorry has nothing to do with numbers.

The privilege level has to do with a hierarchical way of determining which extensions can use a route given the privilege level associated to an extension.

While it may be easy to think of the privilege level having to do with a set of numbers that might be used for internal, local, national or even international dialing such is not the case unless one purposely aligns the dial strings for the locale with that of the privilege and rule.

It is merely a way of setting a security level by which an extension is allowed to use a rule.

If you have set a rule, regardless of what the dial string is, as international, then only those extensions that also have an international privilege can use that rule. However, because international is a higher level than the other levels, they can dial the other rules that are national, local, etc… However, an extension with a local or national level cannot dial out using a rule for international as they do not possess the privilege level to access that rule. You can use whatever dial string you please in any rule and then restrict the access by setting a privilege level or user source callerID.


#16

What does the rule look like for the internal call using follow-me?
You could try setting the rule privilege level to internal, which is the lowest and virtually should be able to use.


#17

I wouldn’t be so sure about that, the UCM manual says the following:

An outgoing calling rule associates an extension pattern with a trunk used to dial the pattern. This allows different patterns to be dialed through different trunks. For example, “local” allows 7-digit dialed through FXO port while “long distance” allows 10-digit dialed through a low-cost SIP trunk. A failover trunk can be set up to be used when the primary trunk fails. Note: This panel only manages individual outgoing calling rules.


#18

It indicates “for example”. How would GS know what is a applicable dial string for every locale in the world for local, national and international?

Here is what the manual actually indicates for privilege level without the “for example” -
Select privilege level for the outbound rule.
• Internal: The lowest level required. All users can use this rule.
• Local: Users with Local, National, or International level can use this rule.
• National: Users with National or International level can use this rule.
• International: The highest level required. Only users with international level
can use this rule.
• Disable: The default setting is “Disable”. If selected, only the matched source
caller ID will be allowed to use this outbound route.
Please be aware of the potential security risks when using “Internal” level, which
means all users can use this outbound rule to dial out from the trunk.

As stated in the manual, I could just set internal, the lowest privilege level and anyone can use the rule no matter the length.


#19

I’m not sure, but I had tried with national and it did not make me compose more than 10-11 digits.
I have to try but I’m almost sure.


#20

Very clear about these privilege level.
Come back to follow me : I already set Privilege lv of outbound call to internal , but the call from external still can not go through . Is there any security setting I need to check ?