Flash Rom failure


#1

Hi

I purchased a 6202 25 months ago ad have not had occasion as far as I remember the need to upgrade the firmware, the unit had worked well from it’s original setup and still does. I notice I had missed quite a few updates so tried to take it from 1.0.12.19 to 1.0.13.14 and according to unit (Status - General) it didn’t stick. So after trying a couple more times I contacted support to be told (after some questioning) the flash memory on the UCM cannot perform read/write anymore, its “Defective Approved” and I should contact the supplier. To be told by the supplier it’s out of warranty nothing they can do.

End of story!

I’m shocked that it’s the end of the story, as it can’t be wear and tear it clearly is a defective Flash Rom from very early on. and who tests that occasionally to see if its still working?

I think I’m suppose to throw it away and buy a new one, I cant get anyone to talk to me at Greadstream or voipon about a solution (apart from the above I guess)any thoughts would be welcome

Regards

Paul


#2

Normally resellers give a 12 month warranty and it seems your unit falls into this category. However my experience as a reseller is that if Grandstream approve it as defective, even outside that period, you should contact your reseller with the GS ticket number. They will then liaise with GS to replace even though the warranty period has run its course.
I’ve done this a couple of times in the UK with UCM units that have exhibited the same issue as you describe again outside the warranty period.


#3

Thanks

I have tried that without success, I will send a request to them to contact Grandstream with the Defective Approved Ticket number again and see what happens

Thanks again


#4

If that doesn’t work the only alternative I can suggest is contact the GS distributor in your country


#5

They should not have a problem unless the reseller in not a Grandstream authorized reseller.


#6

I had 3 units from the same time period that all had the same issue. GS and Gentec (Canadian distributor) were amazing. 2 were out of warranty, replaced with zero problem. I assume there was a known problem as they didn’t even trouble shoot the third unit, just asked for the MAC and approved the return.

Essentially, I think there was a quiet recall without actually recalling the devices.

If the reseller won’t budge, get a new reseller.


#7

Thanks guys

I’ve resent the info to the supplier, GS (USA) and GS (UK) all are now “looking at it again”

They are all very slow responding, I’ll come back when I hear anything.

Regards Paul


#8

If you’re in the UK the distributor is usually very good at responding to issues…in my experience that is
This issue of upgrading UCM units past 1.0.9 has been a little problematic. I’ve had the same experience with 3 units all out of warranty but in each case the distributor replaced them anyway


#9

Hi

After a bit of persistence with Grandstream, telephoning HQ in the USA sending detail to just about everyone I could, the UK distributor got in touch and changed it out .

Thanks for the help guys all worked out in the end

Regards

Paul


#10

Glad to hear.