Firmware Update GXP2160


#1

I tried updating the firmware from the phone and it reboots normally. Is there a way to check that the phone can reach the Internet? I’m using an old firmware.


#2

You need to update old firmwares in steps with intermediate firmware versions on the firmware download page. If you just try the newest 1.0.9.x from pre-1.0.7, it won’t update.


#3

The firmware is version 1.0.5.18 and the “Firmware Server Path” to “firmware.grandstream.com”. The “Config Server Path” is set to “192.168.1.92:8089/zccgi” which is the UCM6100 PBX. When I visit “192.168.1.92:8089/zccgi” there is no response.


#4

you cannot upgrade directly 1.0.5.18 to newest, check GS firmware page and upgrade in steps.


#5

Ok, is this right?

  1. The firmware is version 1.0.5.18 which is higher than 1.0.4.x so I skip 1.0.7.97. “If the GXP21xx phone is on firmware 1.0.4.x or lower versions, please upgrade to 1.0.7.97 first.”.

  2. Upgrade to “http://firmware.grandstream.com/gxp21xx/1_0_8_56

  3. Then upgrade to “firmware.grandstream.com/gxp21xx/1_0_9_108

I entered the URL into the “Maintenance” and “Upgrade and Provisioning” “Firmware Server Path” and rebooted the handset. The firmware ID under “Status” “System Info” is still the same.

Is the phone even trying to upgrade the firmware from the provided URL?

Those URLs come back with HTTP status code 403 when opened in Google Chrome.


#6

Make sure you enter the url without the http:// prefix and select the http radio button


#7

That worked. Thank you.