Firmware shows up to date


#1

Hello,

Trying to upgrade firmware on a DP750 but always says UP TO DATE.
I tried local upgrade too but it is the same.

Thank you.


#2

“Verify host when using HTTPS” = no

firmware server path -> firmware.grandstream.com

then press “START”.

if I were you automatic upgrade I would deactivate it


#4

After I saved I pressed reboot, and then start.

After reboot I login again.
Firmware status says UNKNOWN
I pressed “Check Firmware” and says “UP TO DATE” 1.0.1.20


#5

you connected the phone as I told you directly to UCM without switching or anything else?
If you have done so, all you have to do is open a ticket.


#6

That is one of the first firmwares and I remember I had a little trouble upgrading.
I think I had to do the jump to 1.0.2.x before I could go any higher.

For DP750/DP720, firmware 1.0.0.99 (The first public released beta firmware) and
all above can upgrade to 1.0.4.7 directly, no transitional firmware is needed.

That would mean a specific firmware path:
The notes say:
The jump from 1.0.4.x to 1.0.7.x changes the entire firmware.
firmware.grandstream.com/Release_DP75x_1.0.4.10
I believe that is the path for 1.0.4.10
Likewise I bet the 1.0.2.16 is
firmware.grandstream.com/Release_DP75x_1.0.2.16

I would try a younger version and see if that helps.


#7

Thank you for your answer.

I have apache setup on my machine 192.168.1.81.
I placed dp75xfw.bin for version 1.0.2.16 on the root.
I changed the Firmware Server Path to 192.168.1.81.
Reboot and pressed start.
Everything is the same.


#8

I had not read that you had the fw release of the Middle Ages :stuck_out_tongue:
you are right anyway @lstutesman , it should be updated in steps like.


#9

Thank you. Which version should I start with?

Using SSH for version 1.0.2.16:


#10

That’s where I would start.
If it won’t go, I’d open a ticket.

maybe @grandstream has an insight.


#11

Checked the log for my apache server. The DP750 does not even contact my server to find the firmware…
I have checked and the server is accessible on the network.


#12

I suggest to check any network connect issue or dns issue, if the device didn’t reach your HTTP server, it’s not upgrade failed, but failed to download the fw file.


#13

you should be able to upgrade from 1.0.1.20 to 1.0.7.5 without issue if your HW is not too old (before official launched).


#14

Thank you but network is ok.
I have 5 DP720 connected to the DP750 (192.168.1.152) and all are registered with a Yeastar S20 (192.168.1.200).

The fact that the upgrade via SSH closes connection without even trying to connect is normal?


#15

So, when you use a browser and type http://192.168.1.81, what happens?

You might want to use TFTP as it may be a more easily defined path that is implicit.


#16


#17

I would try TFTP and see


#18

Thank you. Tried but it is the same behaviour.
By the way, I am a Computer Engineer and this is an IT company so I am 99.9% sure this is not user error on my part :frowning:

Any ideas? Thank you


#19

If you haven’t already, I’d open a ticket.


#20

Did it just now thanks.


#21

Could you please capture a wireshark trace or use the packet capture tool on web, enable the Syslog to DEBUG level for more details. I’m expecting some firmware mask error in the syslog or HTTP send to wrong address by the device. A trace will help us to locate the problem.
I guess the helpdesk will ask you for a packet capture as well.