Firmware 1.0.7.7 for WP820 released as official

firmware-release

#1

Dear Grandstream Customers,

Firmware 1.0.7.7 for WP820 is now released as official. Here is the link for the WP820 release notes:
http://firmware.grandstream.com/Release_Note_WP820_1.0.7.7.pdf

The firmware and release notes can be downloaded from:
http://www.grandstream.com/support/firmware

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.


#2

#3

Hello. Please note that we have several Grandstream WP820 in the office with Anveo. They all broke after this update. Outgoing calls drop after 20 seconds. No problem with incoming calls. All phones started to present that problem as soon as they go updated (sadly, I had auto-update set up in all phones, lesson learned).
We are reverting back to Firmware 1.0.5.5 to correct the issue. Could you please look into it?
Note: We have those phones used as remote extensions at multiple locations (different networks) and they all are presenting the same problem after the update. They all were working well before 3 days ago.

Please know that back in 2016 this already happened to one of your firmware:

Thanks in advance.


#4

Hi,

Could you please take a debugging capture of an outgoing call on the WP820 on 1.0.7.7 and send it to us for analysis? On the WP820 web UI, go to Maintenance->System Diagnosis->Debug. Press “start” then perform the call until the issue is reproduced. Stop the capture and press “List” and download the package. Please also provide the device configuration. You can download the device configuration under Maintanence->Upgrade->Config file.

Thanks


#5

After upgrading a 1.0.5.5 device to 1.0.7.7 the primary SIP account lost registration. I have tried everything I can think of including a factory reset and total reconfiguration, but I can’t get the device to register with my FreePBX server. Any advice other than downgrade to the last firmware?

I cranked up the debugging on asterisk and I don’t see any requests coming in from the device. I can see REGISTER requests for other devices, but I’m getting nothing from the 1.0.7.7 hitting the log file at all.


#6

Hi,

Could you please download your device configuration (Maintanence->Upgrade->Config file) and attach it here for us to review? Is your FreePBX server located in your local network or on external network? Any special configurations?

Thanks


#7

Hi Rick,

Thanks for your help. Yes, the FreePBX server is on the same local network as the phone. There’s nothing special about the setup, just a basic PJSIP extension which the device registers to. I’m attaching the requested config file (had to ZIP it to allow upload).

config.zip (5.5 KB)

Let me know if there’s anything else I can do to help troubleshooting.

Dominic


#8

Hey,

I noticed in your config file you are using TLS for registration. That is a tricky one to troubleshoot. Here are some settings I suggest you try System Settings->Security Settings->TLS->Minimum TLS version set to “1.0.” If there’s any sort of certificate your using you may want to try re-uploading and reboot the device. Also under Account1->Advanced Settings->Only Accept SIP Requests from Known Servers, uncheck this feature for now. Try to see if these settings help. If the request isn’t going through likely the TLS handshaking is failing. If the settings don’t help, you would need to enabled debug syslog, then do the one click debugging to capture the logs for us.

Thanks


#9

Wow, you’re good! That did it. Now I need to figure out why my FreePBX system can’t use modern TLS, but that’s a separate problem. Thank you so much for your help. I really appreciate it.


#10

No problem. I was looking through the release at the changes that may impact TLS. That seems the most likely culprit setting but yeah you should try to use systems that have TLS 1.1 as minimum (1.2 preferred) for better security.

Thanks


#11

@osebelen

In your trace, the 200ok from Anveo Server shows a contact URI like this: sip:127.0.0.8;anveohash=enc-aKu.c6lbd8WvXTrJC68bdTrQX6g1cH8Qch**

127.0.0.8 is a loopback address (internal address) and is likely the culprit of why your WP820 isn’t able to route the ACK back to the server. I’m surprised if 1.0.5.5 can work fine in this scenario. Could you please check with your SIP provider on the contact URI?

Thanks


#12

After dialing a number, then pressing “Call”, a popup with two options “Audio call” and “Video call” appears. I have Enable Video Call uncheck in settings. I do not want people to see this “Video” option, just dial the number.


#13

Hi,

This is a known issue. We will include the fix for it in the next release.

Thanks


#14

Hi, it seems we cannot save the configuration of Automatic Upgrade section. We tried to set Automatic Upgrade on, randomized on Sunday 0-23, then saved. Returning back on that page later, it had turned back as before with Automatic Upgrade set to off.


#15

Hi,

It seems there is some web interaction issue with that setting. We will check on the issue.

Thanks


#16

I have the same problem - outgoing calls starting dropping recently after ~15-30sec.
I use Anveo.

Tried to set TLS min version to 1.0 as above to no avail.

Can you please help debug this?

PS Downgrading to 1.0.5.5 helped for now. Also found the config file but cannot attach it here (“new users cannot attach files”). Here is a link: https://drive.google.com/file/d/1CdyoZWIniO3V3gGl43MMD9QkxdPUblE7/view?usp=sharing


#17

Hello,

The issue with the Anveo server appears to have been a bug. The workaround on 1.0.7.7 is to put the SIP server (including port) into the outbound proxy field as well as the SIP server field.

Thanks


#18

Hello. The very useful feature is permit scheduling reboot still unavailable. Some errors cannot be repaired until WP820 is restarted. Please add this feature as soon as possible. We are grateful for your assistance.


#19

Could you please explain these errors in details?

Thanks


#20

We have over 70 WP820 devices, each device have a different error as below:

  • Sometimes, the microphone has problem, the answerer didn’t hear anything.
  • When the phones were received a call, its screen were displayed an incoming call but no ringtone even if we turn on ringtone and turn the volume up to maximum.

The above errors can be fixed by restarting the phones. Therefore, while waiting for the new firmware, we can manage by scheduling reboots at specified time.

Many thanks.