Firmware 1.0.7.5 for DP750/DP720/DP760 released as Beta

firmware-release

#1

Dear Grandstream Customers,

Firmware 1.0.7.5 for DP750/DP720/DP760 is now released as Beta. Here is the link to the release notes:
http://firmware.grandstream.com/BETA/Release_Note_DP7xx_1.0.7.5.pdf

The firmware and release notes can be downloaded from: http://www.grandstream.com/support/firmware

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.


#2

#3

This firmware just bricked my base.

After upgrade, the LAN LED doesn’t lit up, doesn’t connect to LAN either. Can’t go to Web UI and handsets can’t register.

I tried rebooting. Nothing so far. Can’t factory reset via hardware button.

Here’s what it does in loop:


#4

I tested my device, normally the LAN LED should flash even no network cable connected. There is something going wrong on your device.

If possible, could you provide a video to record from when you start to press the factory reset button (page button for 30 seconds) until the device stayed in this LED pattern? We would like to make sure if the LED have ever lid once?

The third LED keeps quickly flash means the device is trying to register an account, which means the device software is working fine, but the network module (maybe hardware) is not working at all.


#5

So, it finally got to work after an hour or so of this loop:

  • all blank (1s)
  • all lit up (1s)
  • power lit up + activity flashing (no lan led) (stays like this for like 5-10min)
  • power lit up only (1s)
    And goes again.

I managed to get to web UI and the firmware has been updated but it seems like it was trying to flash the update multiple times. The handset has been updated succesfully when the base was up again.


#6
  • all blank (1s)
  • all lit up (1s)
    this means the device is upgrading. I don’t know why your device tried multiple times, there must be some failures and it retries, glad it worked out eventually.

#7

With 1.0.4.10, if you have “Enable Onhook on Cradle Reposition” turned on, and placed the phone in the cradle while a second call was ringing, the active call would disconnect and the second call would begin ringing.

Now, with 1.0.7.5, when you place the phone in the cradle, it rejects the second call and leaves the active call active.

In order to workaround the original problem, I have taught my users to place the phone in the cradle and then pick it back up in order to disconnect the active call and answer the second. Now this behavior is different.

Could we please just get an option like “(Any) On-Hook affects active call yes/no”?

I greatly appreciate the new ability to at least select which call is affected, but teaching someone to select the active call before pressing on-hook is counter-intuitive, IMO. As I understood it, that route was chosen in order not to change current behavior. However, the change did change the current behavior that worked for me - active call on-hook when placed in cradle.


#8

#9

hi,

How do you make to work again, I tried different solutions I find in the Internet so far nothing is working. I tried to enter via ssh with putty, but when enter the password automatic close the windows, the web gui don’t work either.


#10

You need to be lucky and get the firmware path back to the official one. Then after a few reboots it should downgrade by itself.