Firmware 1.0.6.32 for GWN7000 released as official

firmware-release

#1

Dear Grandstream Customers,

Firmware 1.0.6.32 for GWN7000 is now released as official. Here is the link to the release notes:
http://firmware.grandstream.com/Release_Note_GWN7000_1.0.6.32.pdf

The firmware and release notes can be downloaded from:
http://www.grandstream.com/support/firmware/

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.


#2

#3

Since upgrading to this firmware I’ve found a big drop in internet speed.

I have a gigbit connection (1000 mbps down / 500 mbps up, PPPoE), and with 1.0.4.23 I used to get around 800 down, 400 up on a pretty consistent basis.

Since the upgrade to 1.0.6.32 speeds are now capped to just over 300 down or up.

If I plug in my ISP provided router (Fritzbox 7490), I get 800+ down 400+ up.

This is pretty disappointing, since I see one of the release notes was ‘improved PPPoE’ speed…

Thanks.


Firmware 1.0.9.4 for GWN7000 released as official
#4

@grandstream I have had similar results. I had the same issue with WAN PPPoE speeds on the beta release (1.0.6.28), which was supposed to be fixed with this release, but apparently not.

I am currently getting the same 350 down / 300 up on this release with the GWN7000, where I was getting 850 down / 500 up on the previous firmware, and can get pretty close to advertised line speeds (>900 down / 500 up) with the same ISP provided router (FritzBox 7490).


#5

Ahhhhh. What? This seems to have broken my routers functionality. I have the same speed issues that others have mentioned, I can no longer get above 300 Mbps down or up and my 2x 7610 APs no longer seem to work, and they won’t update to the latest firmware. This new firmware was obviously not tested properly, how do I roll back to the previous version, or will you fix these issues promptly?


#6

I’ve managed to manually update my 2x 7610s and re-add them to my gwn7000 router. Along with the reduced speed issue I’ve also found that the scheduling of the AP LEDs is now also broken. Pretty disappointing update.


#7

Yes, I noticed the same thing - the update deletes any schedule set for the LEDs.

I don’t know how this update passed QA. The main function of a router is to route the internet to the internal network, so to break that functionality so severely is alarming.


#8

I can confirm that downgrading to 1.0.4.23 brings the speeds back to what they were previously.


#9

I figured out how the scheduling works for the led etc now. Not very obvious. But when will this speed issue be resolved? A gigabit router that can’t route that fast seems a little pointless?


#10

Can you tell me how to downgrade back to 1.0.4.23? I might need to refresh the firmware on my device, I currently have 1.0.4.23 but I have none of the functionality that the manual promises me. I can’t see LAN ports, I can’t assign LAN functionality under router, I can’t change firmware without a tftp server which doesn’t seem to work at all…


#11

50+ of these GWN7000’s deployed at customer sites. Yes, speeds about half across the board. Wired.


#12

It’s a right pain in the backside to downgrade to an earlier firmware. You need to to use the tftp option to transfer it from a computer (I used Solarwinds free tftp for Windows). Once you’ve downgraded the firmware then you need to factory reset your AP’s and upgrade them back to the appropriate matching version. Quite a song and dance, which puts me off trying any new firmware until it’s clearly working.

Older firmware can be found here:
http://www.grandstream.com/support/firmware/previousfirmware/#GigabitRouters

If you can’t get it to work I’d suggest contacting the product support.


#13

I haven’t even managed to get the SolarWinds tftp working. Looks like the Grandstream wants the IP of the SolarWinds to be on the WAN(?) side of the device - there is no way for me to make that happen. Any suggestions?


#14

Trying tftp using the instructions given in the manual for version 1.0.6.32 -

  1. Unzip the firmware files and put all of them in the root directory of the TFTP server; DONE
  2. Connect the PC running the TFTP server and the GWN7000 to the same LAN segment; DONE connected PC to LAN port on GWN7000
  3. Launch the TFTP server and go to the File menu→Configure→Security to change the TFTP server’s default setting from “Receive Only” to “Transmit Only” for the firmware upgrade; DONE
  4. Start the TFTP server and configure the TFTP server in the GWN7000 web configuration interface; DONE
  5. Configure the Firmware Server to the IP address of the PC; DONE
  6. Update the changes and reboot the GWN7000 FAILS - SAYS UPGRADE FAILS

Public http server path for the firmware doesn’t exist. Wrote to support. Got the path for 7600 series devices. Twice. Nothing for the GWN7000 specifically. Still waiting on a response.

Note: I’m currently on 1.0.4.23 which I understand is more stable, but…doesn’t allow me to configure a static route or any LAN port properties so stuck between a rock and a hard place.


#15

@grandstream it has been over 2 months since this firmware was released, yet there seems to have been no progress on resolving, or even acknowledgement of, the WAN<->LAN speed issues with the 1.0.6.32 release.

Is there a fix/release in the pipeline to address this issue?


#16

@GS_Tian Same question?


#17

I’ve seen some complaints about throughput performance. I noticed that the default MTU for each WAN connection is set at 1500. I have two PPPoE connections, so I decided to test the throughput using ping www.google.com -f -l xxxx (xxxx being packet size). I found that the packet size I needed for my connections to avoid fragmentation was significantly lower than 1500, and different for my two connections. You might want to check this as well and see if you get better performance. I found that I actually had to set the MTU to about 1428 - and for purposes of sanity I used the lower MTU for both my WAN connections even though they both came back with different values when I ran the test.

Of course now having run it for a while syslog is showing me errors:
Mon Jun 17 14:17:32 2019 daemon.err pppd[22519]: Interface eth3.2 has MTU of 1428 – should be at least 1500.
Mon Jun 17 14:17:32 2019 daemon.err pppd[22519]: This may cause serious connection problems

This makes no sense because when I ping with the MTU packet size at 1500 it shows fragmentation of packets…will have to wait and watch.


#18

normally you never leave an MTU a1500, on any vendor and any model.
1500 would be the optimal value in “local lan”, on the web will never be so, because of the latency, the criticality of the cable, the Manager etc. …
I usually leave 1500 alone when I am in front of Fiber. However, I find your pointing useful and professional.


#19

I was happy to leave it be as the default value.

Some more information:

I have two fiber optic providers, with each having 150mbps connections up/down.

Today, as I was fixing my failover+load balancing issue, I decided to test each connection individually to see where packet fragmentation was happening, and found that one was fragmenting above 1440 bytes and the other was fragmenting above 1428 bytes.

That’s why I changed it, and for purposes of sanity I retained the lower value on both.

As it turns out you cant change the MTU value on the LAN part of the GWN7000 anyways, so this was entirely on the WAN side.

I do have an unrelated issue still to fix, which is that my secondary connection keeps dropping. I’ve set both connections to gigabit Ethernet full duplex but for some reason the fiber modem on my secondary connection keeps hanging - and needs a restart every few hours. Any ideas?


#20

More than four months later and no sign of an update for this major issue. Unfortunately, it appear that this product is now abandonware :frowning: