Firmware for GWN76xx WiFi Access Points released as official



Dear Grandstream Customers,

Firmware for GWN7600/7600LR/7602/7605/7605LR/7610/7615/7624/7625/7630/7630LR/7660/7660LR/7664/7664LR is now released as official. Here is the link to the release notes. The firmware and release notes can be downloaded here.

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.



Unfortunately a previous solved bug was reintroduced with this firmware.
Firmware seems to have a severe VLAN bug - WiFi Access Points - (


No way, that is really really bad. Thanks for warning, though.


Dont know if its the firmware or the cloud update, but the total (client usage) is wrong, some of the client are alreade 5 hours on, watching youtube, but says the total is 203.4 KB. Impossible. We use GWN7605 and at some places GWN7630LR devices.


It’s the cloud update.


Thanks for letting me know. Hopefully the will fix it soon.


Thank you very much for the hint. Have you already opened a ticket at Is Grandstream aware of the problem?


Not yet, will do later.


So, has Grandstream already confirmed the bug?


Unfortunately (is it?) I’m not able to reproduce till now. Only thing I changed before this firmware upgrade was deactivate 802.11 k/r/v. Will monitor for the rest of the weekend, might test with this activated on the weekend.






It was giving problems on a single (older) device.


ah ok, I misread, that Grandstream had disabled that features

keep in mind that you can also activate/deactivate the single setting


Not sure if it is related: enabled Voice Enterprise yesterday and this morning I ran into the same problem. Updated my ticket, hope support can find a cause. Disabled Voice Enterprise, will keep a look at the logging.


Also with Voice Enterprise disabled, the problem is occuring. Might be related to my GWN7605LR, downgraded its firmware and reenabled Voice Enterprise. Kepping a close look at the router log.


I can confirm bug. Client reported problem after upgrade.


And I still have open ticket for first case reported. It makes me think that bug was never solved. Just temporarely resolved by “accident”. :grinning:


What type of accespoint(s) do they use?