Firmware 1.0.20.20 for UCM6202/6204/6208 is released as Beta

firmware-release

#1

Dear Grandstream Customers,

Firmware 1.0.20.20 for UCM6202/6204/6208 is now released as Beta. The firmware and release notes can be downloaded from:
http://www.grandstream.com/support/firmware

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.


#2

#3

Park Keys on GRP 2614 still dont wont work when programmed to MPK keys via zero config. Also Monitored Call Park is not available as a key option in Zero Config on MPK’s. You need to manually program each key via the web interface to Monitored Call Park for the keys to light up.
I’ve reported this to GS Support and it really needs to be addressed.


#4

Thank you for the feedback. Have you downloaded the latest GRP templates from the Model Update page and recreated your templates?

We will look into this.


#5

Did that, 2 of 4 park keys lit up but after a reboot none worked. Only manually set Monitored Call Park works on MPK Keys (Bottom Keys). VMPK seems to work (Main Screen).

Good call though.


#6

Just to confirm, your template version for GRP2614 is 1.5?


#7

Yes, its at 1.5


#8

hi @GS.Jimmy

I’m sorry to tell you but the GRP templates on UCM6200 and 6510 are unusable, you better prioritize and fix them as soon as possible, otherwise the GRP series will be difficult to sell for UCM installers. :frowning:


#9

Thanks for the feedback, damiano. We were made aware of the severe issues with provisioning to GRP26xx during the 1.0.20.19 beta and should have addressed many of them in this 1.0.20.20 beta along with new GRP templates. Could you please provide more details about your provisioning issues?


#10

hello @GS.Jimmy,

Currently I don’t use version 1.0.20.xx as it’s still not stable, I tried to install it by 2 customers but I had to go back to 1.0.19.
About the GRP template (I guess it’s the same version on 1.0.19 and 1.0.20 as the same sw release if I’m not wrong), I found the strangest problems:

  • key programmed with the xxx function that after provisioning became yyyy on the phone
    (for example, a BLF key becomes a Multicast key instead)
  • key 2 programmed as line 2 of account 1 that was empty
  • I had created custom GRP templates and after the model upgrade they were deleted, so I lost a lot of work :frowning:
    It’s urgent to be able to import/export custom templates
  • there’s a lot missing.

The very strange thing is that the GXP21XX template has always worked well on UCM, GRP instead struggles to be reliable and stable.
Obviously you have to take mine as constructive criticism, it is in everyone’s interest that everything works well :slight_smile:

If you can answer me a question, is UCM fw 1.0.20.xx based on Asterisk 13 or 16?
I read a bit everywhere problems on Asterisk 16 and many people recommend to stay on 13 for now.
Last thing, Asterisk 16 if I’m not mistaken has implemented a kind of “softphone” via the web. It would not be bad …

Thank you for your attention.
Damiano


#11

Correct, model template versions are independent of UCM versions.

This is being worked on.

Do you mean there are a lot of options missing for VMPKs and MPKs?

UCM 1.0.20.x is still on Asterisk 13.


#12

thank @GS.Jimmy you for your answer,

probably all the problems that I detect with GRPs with the fw 1.0.20.xx would not be so dramatic.
I was convinced that the version of a template was different identical even if you change fw of UCM (I thought to understand that the xx 1.4 template was identical for each version of UCM). You never stop learning :slight_smile:
Is the PJSIP driver used?


#13

Could you explain in what way the provisioned Call Park keys don’t work? On my end, the functionality of parking and retrieving calls is working fine. The only thing that does not appear to work like GXP phones is the LED status indicator for parking extensions, which does not light up green or red depending on whether a call is parked on it or not.


#14

This should have been resolved for VMPKs and MPKs in 1.0.20.20. However, we have discovered this issue for other key types and will work on resolving them as soon as possible.

I can’t seem to reproduce this with the latest firmware and GRP model template.


#15

Correct they work but don’t light up but also give no indication that a call is parked on that button.


#16