Firmware 1.0.20.17 for UCM6202/6204/6208 is released as Beta

firmware-release

#1

Dear Grandstream Customers,

Firmware 1.0.20.17 for UCM6204/6204/6208 is released as Beta. Here is the link for the release notes:
http://firmware.grandstream.com/BETA/Release_Note_UCM6xxx_1.0.20.17.pdf

The firmware information and release notes can be downloaded from:
http://www.grandstream.com/support/firmware

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.


#2

#3

I tried to change UCM login username (example I entered admin2000 instead of admin), logged in several times with admin2000 and everything worked.
So I restarted UCM, since that moment I don’t access neither with admin2000 nor admin, and obviously I can’t even get the pswd email sent to me for recovery.
Please check this, if it was a bug it would be very important to fix it.

other problems detected I posted them on


#4

the display on the Extension page of the existing or not existing voice message field for each extension has disappeared. It was very convenient and indisputable to have a general overview of existing messages. I sincerely hope it returns to be there.


#5

on zero config you can order any field except the extension field, it would be useful especially if you have many existing phones.


#6

I saw with satisfaction that on Zero Config that you have increased the possibility to add pcodes on custom models in addition to 60, it would be the best to export custom models.


#7

Long standing complaint by users and tech alike who use Zero Config. I fully agree.

Would also be good to add a search field like on the extension page.


#8

There is one. In the filter dropdown. Choose EXT or MAC and you can search all phones.


#9

Good observations. Handy. But, IMHO, it’s not the same as being able to browse through all the registered phones on the system in a particular order.


#10

I haven’t been able to load the new firmware yet. Can someone advise if they’ve fixed the big time-waster of not being able to bulk edit and/or download/upload extensions to set the voicemail-to-email settings (send/do not send and keep or delete after sending)?


#11

Isn’t that email in the bulk editor already? (Might not be working tho, never tested)


#12

Actually, it would be great to know which devices are connected and which are not.

GS way: show all devices and good luck finding out what’s connected.

3CX way: show only connected devices and good luck finding one phone in 250 extensions.

Can we do both please?


#13

Nope. That’s why I’m asking. It is so time wasting having to go extension by extension in a 60 extension office to check and/or change these settings.


#14

What about the “Edit All Sip Extensions”? I think it’s a different editor (oddly).


#15

You can look at extensions and see who is registered. Unfortunately my experience is that it shows phones that were registered but are not currently registered as registered. Not sure how long it is before it gets caught up with reality. And most likely it is a setting I could adjust if I knew where to look…


#16

It takes almost an hour because the default registration expiration on GS devices is 60min.

3CX sets it to 2min to avoid this.

And the list only shows an IP:port. Not a model, firmware or anything. You have to go in ZC and search the IP to find the phone. Just a bit annoying but less important now since GDMS is integrated. No more need for ZC (almost, still waiting for on-premise GDMS)


#17

I just installed the firmware. Unfortunately the ability to do bulk or upload edits for voicemail-to-email is still notably missing. :frowning:


#18

I installed the firmware, activated “developer” in GDMS and
entered the region/Mail/GDMS Pass/API-ID and secret key to UCM GDMS Settings and tried to authenticate -> Authentication failed
Does it work for you to sync with GDMS?
Or is there something other to be done before?
Do I first have to sign as developer( as shown under View more details )? at: https://{gdms_domain}/oapi/xxx ?
If yes: What means xxx here?
I also changed the username and password in UCM to more secure
(UCM told the first time I tried to authenticate)


#19

I had a similar issue with authentication from UCM->GDMS and it turned out to be a $ sign in the password. Once I removed this authentication worked.

https://forums.grandstream.com/t/firmware-1-0-20-17-for-ucm6510-is-released-as-beta/39533/5

You don’t need to sign in via the API, in fact you can’t do this. All you can do is obtain a time limited token to interact via the API


#20

In the 3CX phones tab type the extension number, name, handset model etc in the search box at the top and it will filter results for you