Firmware 1.0.17.8 for UCM6301/6302/6304/6308/6300A/6302A/6304A/6308A released as official

firmware-release

#1

Dear Grandstream Customers,

Firmware 1.0.17.8 for UCM6301/6302/6304/6308/6300A/6302A/6304A/6308A is now released as official.
Download Release notes
Download Firmware

For UCM6300 with RemoteConnect, make sure to download the latest Wave applications (1.0.17.x/1.17.x release) from here.

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.


#2

#3

This has been a problem for a few revs, but the dashboard is getting out of hand. I shouldn’t have to maximize my browser window to not make everything be squashed.

You have the stupid Remote Connect and GDMS nag notices in a fourth column and the storage status below that and there’s a bunch of unused space below the interface status.

Move the storage info below the interface status and get rid of the absolutely worthless fourth column with the nag notices.


#4

you should report via ticket:


#5

FYI, after updating to 1.0.17.8 firmware on a UCM 6301 I could no longer forward (in features tab) to an extension’s own voicemail box. I could forward to any other voicemail box… just not the ext being programmed.
Its own extension was listed but unavailable to be selected.


#6

do you mean this?


#7

Yes, and to be clear. When I upgraded to the new firmware any existing ext’s already forwarded prior to upgrading were still listed, but when I went to add “call forward always” I noticed I couldn’t select my own voicemail box. So, I then changed the Call forward No answer to a general delivery mailbox & saved changes and then went back to repoint the forwarding to my own voicemail box it wouldn’t allow me to select it.

I also created a new ext and it too wouldn’t allow me to forward any calls to my own voicemail box


#8

to me it works regularly,
open a ticket for Grandstream support:


#9


#10

I just upgraded to 17.8 and had no issue-



#11

I downgraded back to 1.0.11.10 and it works as expected. I then upgraded back to 1.0.17.8 and have the same problem.
Is there “Any Reason” the ucm would grey out the ext as seen in the picture I provided for ext 1113 that you’re aware of?


#12

1.0.11.10 is too old a version,
either you wrote the version wrong, or you are not updating correctly,
it is always necessary to make intermediate FW updates

indeed by doing this (wrong) way to go back and forth in the FW, you only risk making the database precarious and UCM unusable (it’s just a suggestion).
Before making any change you should back up a fw version, and then if anything restore the backeup in the same FW version


#13

I concede that I may be doing it wrong!
When I click on the link you provided adjacent to the UCM6301…under “IP PBX Appliance” it lists firmware 1.0.11.10 for UCM6301. From what I see there is only two options for previous firmware 1.0.9.10 or 1.0.11.10.
Am I missing it somewhere?

I do have a brand new UCM 6301 system that has firmware 1.0.13.9 on it but I can’t find that on Grandstream website.

image


#14

https://firmware.grandstream.com/Release_UCM6301_6302_1.0.13.9.zip
https://firmware.grandstream.com/Release_UCM6301_6302_1.0.15.13.zip

obviously I invite you to check first if the links are valid, and to compare yourself via ticket with Grandstream:


#15

None that I can think of. You might do a backup of the system, then factory reset and then try and/or upgrade. I have no clue if that will work.

The release notes make no mention of upgrading from where you were to the latest requiring any version in-between.


#16

I went back and took a look as the result of a different query by a different user, but also trying to use a call forward function. Now I see your issue. When I looked before, I would see the extension and it would not be grayed out and I could select it. Not being grayed out, I guess I took that as the cue that it would work.

What I now find is that I can indeed select one time, then when trying to save it, I get -

. I got it to gray out one time, like you showed, but now it is just the pop-up. I am running the latest release 17.8 released a day or so ago.

I also find that if I try and do a call forward unconditional for anytime to an external number or VM of another extension that has VM enabled, that it still rings the associated extensions rather than following the rule. I also tried changing the rules for a presence status of away and that too made no difference.

Can you confirm that as well.


#17

I just discovered that it is the Find Me/Follow Me that causes my other forwarding issue -
Please see -
https://forums.grandstream.com/t/ucm-call-forwarding-not-working/52978


#18

Since my last post I have downloaded both 1.0.13.9 & 1.0.15.13 versions (thanks for the links damiano70) and then upgraded to each version in order. All previous versions worked as normal. I then upgraded to 1.0.17.8 and had the same issue as before. I ended up downgraded back to 1.0.15.13 last night since the system needed to be back online Monday morning.
So as a result, I can no longer provide input on 1.0.17.8 but will be interested to see what happens with it moving forward.


#19

I also confirm the error (strangely yesterday I tried it seemed to work, maybe I get confused and I tried with the beta 1.0.17.7),
in my case with voicemail activated, I can create a forward to another extension or external number, but if I use the internal voicemail box, it goes into error.
I would like to clarify that I had not previously activated the voice mailbox 201, but I activated it after the passage to 1.0.17.8, so the problem does not arise with the FW update but it is a (very serious) problem, which is created with this version FW 1.0.17.8.
I also add that I have now created a new extension and the problem is the same.

UPDATE:
just to complete the speech, the same problem does not happen if you use the followe-me with a voicemail destination.
The voicemail 201 used normally does not present any problems.


#20

Confirming same issue cannot set forward destination to own mailbox.