Firmware for GDS3710/3712 released as official



Dear Grandstream Customers,

Firmware for GDS3710/3712 is now released as official. Here is the link to the release notes.

The firmware and release notes can be downloaded from here.

Please contact us should you have any issues. Thank you for your support for Grandstream products.

Technical Support
Grandstream Networks, Inc.



With this version installed, I am unable to configure Account 2-4 (the “Save” button does not work). Any workarounds?


What is your previous firmware version before upgrade? Have you tried factory reset the device and reconfigure it again? (try write down the default password before factory reset). Usually this is caused by upgrade from old firmware version.

Please advise. Thank you for using Grandstream Access Control Products.


Not sure but I believe previous fw was I did purchase the unit recently. Did try the factory reset just now but the save buttons still do not work for Account 2-4.

I did the upgrade because I experienced problems connecting to a linphone account: it registered correctly but with every call, it got a busy signal. The setup does work with a local registrar. The linphone accounts do work within the same network when accessed via a smartphone sip client.


That is strange. Try wipe out and leave the “Configuration Path” empty to make sure the device not be provisioned or configuration overwrite by some server.

Also, open a HELPDESK ticket with Grandstream Support, and export CFG file and upload to the ticket.
This seems to be the configuration issue. Have you tried using different browser to log in and configure the device? What is the browser you are using right now?

Please work with HELPDESK support engineer to help resolve your issue. Worst case is RMA and swop the device, if HELPDESK support engineer confirmed this is not a configuration issue but a hardware defect.

Thank you for using Grandstream Access Control Products.


Ok, thanks.

I did some more testing and the “account saving” issue is browser dependent: newer versions of firefox (>= v105.0.3) & chromium seem to handle it well while firefox v102 does not.

The issue with calling a linphone account remains though. I will make a helpdesk ticket for that.