Factory Resetting a GXP 2140 when you know none of the passwords!



Hi Folks,

I have a bunch of GXP 2140’s that i need factory resetting but i don’t know any of the passwords.

I am prompted for this when i both try a factory reset from the phone and when i am logging in to the internet pages for the phones

I have tried the various default ones listed and tried the MAC address and IP address also

I have trawled the internet in hope but i can’t find anything!

Please can someone come up with a magic cure

Kind Regards


If you don’t have the passwords the only way is to provision the handsets with known passwords.
Firstly set option 66 on your DHCP server to a TFTP server on your network
copy appropriate provisioning files to the root of the tftp server.
reboot the handsets
There was a thread about this with 2160 handsets a week or so ago https://forums.grandstream.com/t/factory-reset-gxp2160-without-admin-password/32329/17


@rtl’s favorite topic. @Wansbroughs, you really don’t have much choice (other than finding the person who knows the passwords). You must set up provisioning and create a base configuration to send to the phone(s) to reset everything. This is often done by service providers to prevent someone from taking the phone home from their desk and repurposing it for something else while the employer sits and files paperwork for stolen/missing property.

Need to hard reset my grandstream phone

Hi RTL when i click on the link it says i “do not have access to that topic”

Could you help me further

What file extention is the config file? I have found a load of .xml files that seem to pertain to this particular handset



First of all what firmware version are the handsets on



OK, I suggest that you you upgrade to the latest stable version,
First we need to get access to the handsets. Change option 66 on your DHCP server to the ip address of a PC on your network running a TFTP server. Copy a provisioning file into the tfp server’s directory. Reboot the handset and it should provision from the tftp server. You may want to set up a TFTP and DHCP server off your main network for this.
The attached cfg.xml will provision the handset with a web password of passwordcfg.zip (240 Bytes)



That worked thanks so much!

Is there any way to configure the VLAN setting as part of the cfg.xml file? So that when we send out the config file to all phones they automatically fix themselves?

Restore to Factory Default Setting a GXP1450 without admin password
(SOLVED) Recover GXP1610 with disabled web access and locked menu
GXV3140 factory reset

I suggest you look at this document

and this will give you a reference to the p values


This is @drostoker’s favorite topic. You have to subscribe to the category in order to see it. @grandstream has made it default to almost nothing when you first sign on, which is why everything is posted (incorrectly) in “site-feedback.”

Unfortunately, I never got the welcome email, because I was an old old user when the forum was converted from the old version to this version, so I’m not sure how you subscribe to categories.


The link needed is https://forums.grandstream.com/groups.

Maybe @grandstream should put this link somewhere visible on the site.


If only there were some sort of FAQ that could be used?


I tried this several times without succes.
My DHCP server sends out option 66 with (my laptop with tftp server) I notice it picks up the address but never retrieves the cfg file.
The phone is provisioned from Broadsoft platform where the Keypad is locked down (no factory reset in system menu) and the webinterface is shut down by some setting. The provider doesn’t know how to fix this.

Firmware is so the hard keys (1+9) are not working yet.


I managed to fix it with another DHCP server where I also put option 66 to my laptop and now it did work, I got the newer firmware and I could set the password through the cfg.xml file. Thanks!


Congratulations! It may be a pain to set up, but this is a very effective way to make sure you have 100% control over these phones.



Looks interesting that the DHCP thing works fine for you, I had the same password issue for GXV3240.
Could you send me more detail & step by step the process.



This topic should have been locked and marked as solved. However, since you have the same basic problem, I’ll let the thread hijack go. :slight_smile:

Basic steps are:

  • Set up a TFTP server on your network
  • Set up a DHCP server (or configure an existing one) that sets option 66 to be the address of your TFTP server
  • Put config files that match cfgaabbccddeeff.xml (or just cfgaabbccddeeff, depending on how you make your config files) where aabbccddeeff is the MAC address of the phone
  • The config file should contain all the necessary passwords and configuration to allow you to reset the phone

The config file is easiest to generate from a Zero Config on a UCM device or using the Grandstream XML config generator from http://www.grandstream.com/support/tools

Anything more specific than this is really beyond the scope of this forum. You should be comfortable with setting up and configuring TFTP, DHCP, and XML config files if you’re going to manage Grandstream devices.