Ethernet Down-up randomly

bug
ip-communications

#1

Hi
we have setup of below devices
UCM6510,1pcs
GXW4108,2pcs
GXP1625,35pcs
GXP1628,15pcs
GXP2140,2pcs
GXP2160,5pcs
all the network equipment Ethernet switch are Cisco 2960
the IP Phones setup on Voice Vlan and connected to PC and PC was on data vlan
the IP Phone with connected PC with high volume Ethernet traffic the Ethernet port randomly goes down and up for 5 seconds.
High volume Ethernet traffic like Camera monitoring.
on the same network and UCM I register a Cisco SIP FW phone and it work probably fine
any recommend and help could help
also I have been open ticket account and it is for more that a months and no result.


#2

I guess:
Check if switch not make down.
I think there is a problem on VLan that expire and due to heavy traffic response is to late.


#3

Hi there,

One thing I would try is to connect the IP phone directly to the Cisco switch and check to see if the issue persists. It could be caused by the high traffic experience on the PC side.

Thanks


#4

[quote=“Marcin, post:2, topic:18106”]I guess:
Check if switch not make down.
I think there is a problem on VLan that expire and due to heavy traffic response is to late.[/quote]
NO switch dont down, Ip phone down
I change IP phonw and also switch
and also try it without Vlan same problem
I try with 1625/1628 and 2160
on 2160 it happen more.
mostly the clinet with camera monitoring software connected to ip phone have this problem more
I have this problem on three project installed at customer site.


#5

[quote=“GS.Rick, post:3, topic:18106”]Hi there,

One thing I would try is to connect the IP phone directly to the Cisco switch and check to see if the issue persists. It could be caused by the high traffic experience on the PC side.

Thanks[/quote]
IP phones without pc connected no problem and every thing is ok.
but why it down the Ethernet if the pc connected to the ip phone have high volume traffic.
this mostly happen with software of camera monitoring working on a connected pc to ip phone.
this issue make me so disappointed about grandstream for high traffic environment.
also I try with grandstream support dont get good response


#6

[quote=“kave, post:4, topic:18106”][quote=“Marcin, post:2, topic:18106”]I guess:
Check if switch not make down.
I think there is a problem on VLan that expire and due to heavy traffic response is to late.[/quote]
NO switch dont down, Ip phone down
I change IP phonw and also switch
and also try it without Vlan same problem
I try with 1625/1628 and 2160
on 2160 it happen more.
mostly the clinet with camera monitoring software connected to ip phone have this problem more
I have this problem on three project installed at customer site.[/quote]

Not Switch, PORT on switch. Check status of port in cisco.


#7

[quote=“Marcin, post:6, topic:18106”][quote=“kave, post:4, topic:18106”][quote=“Marcin, post:2, topic:18106”]I guess:
Check if switch not make down.
I think there is a problem on VLan that expire and due to heavy traffic response is to late.[/quote]
NO switch dont down, Ip phone down
I change IP phonw and also switch
and also try it without Vlan same problem
I try with 1625/1628 and 2160
on 2160 it happen more.
mostly the clinet with camera monitoring software connected to ip phone have this problem more
I have this problem on three project installed at customer site.[/quote]

Not Switch, PORT on switch. Check status of port in cisco.[/quote]

this happen even without VLAN configuration.
VLAN expiration ?!


#8

No idea.
GS interface is broken or Cisco down port for some unknown reason.

How much traffic go via this port from PC ?


#9

[quote=“Marcin, post:8, topic:18106”]No idea.
GS interface is broken or Cisco down port for some unknown reason.

How much traffic go via this port from PC ?[/quote]
high volume traffic


#10

So port is down (notice) on switch or not ? (around 10s)
I have 1 cisco switch problem in past which put down port of and up. On other switch no problem.

I was unable to resolve as no access to switch and it logs.


#11

[quote=“Marcin, post:10, topic:18106”]So port is down (notice) on switch or not ? (around 10s)
I have 1 cisco switch problem in past which put down port of and up. On other switch no problem.

I was unable to resolve as no access to switch and it logs.[/quote]

yes it goes down
i try with another manageable Switch same problem, but on many other site with cisco and non cisco no problem
that make me confusing


#12

Can you catch packets ?
Port mirror or maybe some more advanced GS device with packet capture ?
Also if cisco switch have any logs why port is going down ?

I hope there is clue what is wrong.


#13

[quote=“Marcin, post:12, topic:18106”]Can you catch packets ?
Port mirror or maybe some more advanced GS device with packet capture ?
Also if cisco switch have any logs why port is going down ?

I hope there is clue what is wrong.[/quote]
Cisco syslog only show port goes down/up for about 5 second
on grandstream there is no special log on the screen of 2160 show ethernet disconnect…


#14

2160 Ethernet capture
stop when you see port down/up

Then we will have at least full packet trace.


#15

Hello everyone, we have the same problem with the network. We use VLAN for voice traffic and a separate VLAN for PC. Is there any solution to this problem? Noticed yet that this happens when you contact the NTP server. Here is a piece of debug when or after the shutdown:

2017-10-13 07:56:53 Notice 10.60.5.37 user GXP1628_PHONE 0b:82:92:0e:30][1.0.4.67] SIPStack::run: Deleting transaction 0:1001(OPTIONS)
2017-10-13 07:56:53 Notice 10.60.5.37 user GXP1628_PHONE 0b:82:92:0e:30][1.0.4.67] SIPStack::cb_nist_kill_transaction: Kill NIST transaction 1001
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Skew: -939.96 sec Frequency: 0
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Total time elapsed: 1348.00 sec Server stall: 13.92 sec Slop: 1334.08 sec
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Our recieve Time Stamp TZX Oct 13, 2017 07:56:34.3462
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Transmit Time Stamp TZX Oct 13, 2017 07:56:34.3445
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Receive Time Stamp TZX Oct 13, 2017 07:56:34.3445
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Originate Time Stamp TZX Oct 13, 2017 07:56:34.3448
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Reference Time Stamp TZX Oct 13, 2017 07:56:22.4768
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Root Delay=0.0 usec Root Dispersion=396.7 usec Reference Clock ID=127.127.1.1
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Leap Indicator=0 Version Number=3 Mode=4 Peer Clock Stratum=2 Peer Polling Interval=4 Precision=-22
2017-10-13 07:56:34 Notice 10.60.5.37 user GXP1628 [00:0b:82:92:0e:30][1.0.4.67] NTP Days:43019 Seconds:03394.346 Elapsed: 1348.0 sec Stall: 13.9 sec Skew: -940.0 sec Dispersion: 396.7 usec Frequency: 0
2017-10-13 07:56:21 Notice 10.60.5.37 user GXP1628_PHONE 0b:82:92:0e:30][1.0.4.67] SIPStack::snd_message: trying to send message


#16

We are experiencing connectivity issues between GXP2160 and CISCO switches WS-C2960X-48FPS-L. We using those switches for 3 different customers that means 3 different physical locations and different physical (cabling) installations. Each customer is experiencing same issue. Sporadical disconnection (link flap) of the phone (on data link layer) for few seconds few times per day. No specific time during the day and not all of the phones affected. Issue is really strange. We tried to replace some phones (no success), we tried to upgrade firmware version of the IP phones (no success), upgrade of switches performed (no success). Configuration of switchport toward the phone is below.

switchport access vlan 10
switchport mode access
switchport voice vlan 20
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust cos
auto qos trust
storm-control broadcast level 50.00 30.00
storm-control multicast level 50.00 30.00
storm-control action trap
spanning-tree portfast


#17

AFAIR this is energy saving problem on switch. It down port for few seconds.
Turn off this function and it should stop problem.


#18

Hi Marcin, thank you very much for reply, just want to be sure, are we talking about Energy Efficient Ethernet (EEE) feature? Which can be disabled per port basis by command: no power efficient-ethernet auto?


#19

We have this problem in two different location.
One location there is a 2160 with other brand Switch ( not specific config )
We Trun off POE on this port and use another adapter with high Watts(not standard 2160 adapter).

In the other location there was Cisco 2960 Poe switch/Data,voice Vlan/FSTP/… and not only with 2160 but also with 1625, 1628 and 2140 we have this issue.
At this location we put a lot of effort and try capture debug and …
Also I contact Grandstream Support multiple times with technical details and still I have a holding ticket on this issue and don’t solve yet.
Honestly the customer returns all phones and UCMs and we lost a lot of money.
by the way we have been installed and sold more than 20K grandstream ipphones and don’t have this issue in any other project.


#20

I think yes. I remember this from my customer, he turn off some power saving and Cisco stop down port.
100% sure it was related to this.
Any other PoE switch do not have problem with GS, only Cisco as far i got info from customers.