Error in Email setup for Gmail


#1

Hi All,

I am trying to setup Email configuration in UCM6202 on firmware 1.0.14.21.

My configuration for Email Settings are below:

TLS :Enable
Type: Client
Email Template Sending Format: Plain Text
Server: smtp.gmail.com:465
Enable SASL Authentication: Disable
Username: XXXX@gmail.com
Password: XXXXX
Display Name: Grandstream ||
Sender: XXXX@gmail.com

Checked with different settings also, but no luck.
I received a different error code 530-5.5.1. This error is not in the list. I have attached a screenshot for the same.

HELP NEEDED!!


#2

use:

smtp.gmail.com
Enable SASL - yes (By enabling this causes the user name and password to be used; otherwise it is anonymous)

leave the port off. Clicking the TLS setting to on will cause the correct port to be accessed. BTW - SSL is 465, TLS is 587

You may also need to get into the email account at Google and then settings and allow from multiple devices.


#3

I have found this to be necessary on every UCM setup - I use gmail for all of my clients to send out voicemails from the PBX. (Although in the gmail settings I believe it’s something like “allow registrations from less secure devices.” Or something like that.)


#4

Hi lpneblett,

Thanks for the reply. While configuring with the changes you provided, i still received the same 530 error.
And keeping the port number 587 with TLS enabled, i got different error 534-5.7.14

And also to enable multiple devices login, we require G-Suite account which is not possible in my case.


#5

Also you need to allow less secure apps inside the google account.


#6

Hi All,

This is the working status of the Email setup of Gmail.

TLS :Enable
Type: Client
Email Template Sending Format: Plain Text
Server: smtp.gmail.com
SASL Authentication: Enable
Username: XXXX@gmail.com
Password: XXXX
Display Name: Grandstream ||
Sender: XXXX@gmail.com

Have enabled in Gmail: allow Less secure Apps: ON

Tested with Gmail, other email servers, Yahoo, Outlook.

Thankyou all who helped me. Peace Out!!

Regards,
Romush


#7

I have set this up exactly as the last poster above for my gmail account but I am not getting the test emails. When I click TEST it says succesfull but I don’t get any email. When I check the email send log I see the Test but for Send result column it shows “deferred”. Return Code column shows “none”.

I have turned on less secure apps feature in this gmail account.

I am puzzled about what I am missing? Any ideas?


#8

[quote=“spudz72, post:7, topic:20172”]I have set this up exactly as the last poster above for my gmail account but I am not getting the test emails. When I click TEST it says succesfull but I don’t get any email. When I check the email send log I see the Test but for Send result column it shows “deferred”. Return Code column shows “none”.

I have turned on less secure apps feature in this gmail account.

I am puzzled about what I am missing? Any ideas?[/quote]

Which firmware are you in?? it should work.


#9

I am experiencing the same problem on UCM6202 with latest firmware (1.0.17.16).

The “Allow less secure apps” setting is definitely turned on, and I have checked and double-checked the settings to match what is stated to work above. All my emails simply show as “deferred” with no return code whatsoever.

Anyone have any ideas?

Thanks,
Rick


#10

hi rickross,

this above setting i mentioned definitely works. Please try with the port 587
smtp.gmail.com:587
else everything same

regards,
romush


#11

Thanks, Romush. I don’t know what I missed before, but I just tried again with your suggestion, and it is now able to send successfully. Much appreciated.

Rick


#12

Welcome Sir


#13

I made the settings as you wrote but it does not work for me(((
2019-02-08 16:30:45 Test support@ 02-08 16:30:45 support@ deferred none


#14

Email Template Sending : html
SMTP Server: smtp.gmail.com
Enable SASL Authentication: enabled

this works for me

Damiano


#15

i have UCN6204 maybe i need to configure firewall or what something


#16

Please try with port:

smtp.gmail.com:587