Enabling and Disabling DND Bug


#1

On latest 10.0.0.16 Firmware. Testing DND and when I enable DND the phone doesn’t ring as it shouldn’t, but when disabling DND the phone still doesn’t ring. Usually have to wait 5-10 minutes and it will randomly start ringing again or reboot works. The phone is staying registered. Anyone else experiencing this?


#2

I had an issue with it not dialing the system code (disabling local features, relying on system to do the job). We don’t let the phone handle the features because the features don’t work if the phone is registered.

But on the initial firmware (.14, I believe), it wasn’t sending the DND codes to the system as the feature was toggled on/off. Still isn’t working on .16 either.


#3

Hi,

Is this happening every time you enable the DND feature? We would like to see if you could capture a trace for us. On the web UI go to Maintenance->System Diagnosis->Syslog, and set system level to Debug then save and apply. Now go to the Debug tab and start the one click debugging. Try to reproduce the issue and when reproduced you can stop the debugging, click on “list” and download the .pcap file and attach here.

Thanks


#4

I have tested DND the function and I cannot get it to work either - If the DND button applied I can see the DND symbol. If I call the extension nothing happens, the handset does ring and the voicemail on the extension does not kick in. This occurs if the “enable call features” is active or not. If I active the DND function using system codes all works fine and voicemail cuts in.


#5

Hi,

We can’t reproduce this issue in our environment so for those who are having this problem we would need the following information to better understand the issue:

  1. Phone configuration (Maintenance->Upgrade->Config file->Download device configuration)
  2. Enable debug level syslog (Maintenance->System Diagnosis->Syslog, and set system level to Debug)
  3. Provide a packet capture before enabling DND feature (Maintenance->System Diagnosis->Debug->One click debugging. Only check “packet capture” under Debug info menu and save before starting capture)

Note: There is a feature “Disable DND Reminder Ring” and if unchecked it will play a single short ring when DND is enabled

Thanks


#6

I have submitted the files for investigation.


#7

Hi,

Where did u put the files? Could you please attach here?

Thanks


#8

Here you go -

WP800.zip (22.0 KB)


#9

Hi,

We confirmed the behavior on v1.0.0.16. The DND feature code is not working correctly on this build. It is not sending the code when local feature are disabled. It is only enabling and disabling the feature on phone side. On the current test build, this feature is working.

Thanks