Email issue (i know this happens a lot so ive tied this down)


#1

I have a UCM that works fine with MTA, client flipped it over to “client” mode which also works, however its speradic.

I sent a test to myself and gmail and worked fine, then later in the day it wasnt working. I took a packet capture while it wasnt working when i did a test (the UCM said it worked), however i never got the email, what packets am i looking for in thie capture to confirm the UCM really did send the email?

Many Thanks


#2

Follow up to this, ive not had much help from Grandstream other than telling me to change passwords use GMAIL and is the RAM full? (6208 with 30 phones running for 2 days with no voicemail, i would hope the ram isnt full).

However the reason for this thread was to work out what would be in the packet capture, i just ran another and did the same test and i DO SEE SMTP packets this time, so this confirmed the UCM didnt even attempt to send the email on the LAN when it appeared to not be sending emails, it actually didnt even attempted to send them, we rebooted the UCM and its now working.

I know this has been an issue before, has anything ever gotten to the real source of the issue with this?

This UCM is in client mode. Ive had similar issue with SFTP when an SSL certificate changed, it gives up as well without trying, so is there an SSL certificate caching issue in the UCM?


#3

Maybe service was down, did you turn on Service check ?


#4

There was an issue before (2 or 3 versions behind) that if the email to send the notification/voicemail had the same domain as the setting “domain” when using MTA, the UCM didn’t even attempt to send it. The workaround was to simply change the “domain” field for anything else, or switch to “client”.

I haven’t tested it again, but I think it hasn’t been fix. I haven’t seen it in the release notes as fixed either.