DP752 firmware upgrade issue


Hey all,

We got a couple of these DP752 ip phones and wanted to set them up and ran into a two problems.

First they wont fall over to the voice lan, so we decided to try and upgrade the firmware to see if this fixes the problem, but we are stuck on and just tells us “UP TO DATE” when trying to check for new firmware but as far as i can see theres out as the newest release.

How in the hell do i upgrade these?
Things I’ve tried so far.

disabled dhcp option 43 / 6& on the firmware update page.
using my own http server
using firmware.grandstream.com url
using ssh
tried rebooting after telling it to upgrade.

Any good advice?



reboot DP752 and wait,
of course, first make sure that the DP752 regularly reaches the internet.

if there are any problems, do a full factory format of DP752 and inherent laptops first


Hi Damiano70,

For clarification you want me to factory reset the base station and what do you mean with inherent laptops exactly ? :slight_smile:

Thanks for the reply btw


DP752 is a dect base, will you have paired DP720 / 722/730 ?


Ah yes i have a DP720 thats gonna be paired with it.

I did a factory reset on both and i’ve been monitoring the packets on the dect base and its not showing any get packets to firmware.grandstream.com ( but it does get ntp updates from the outside ntp server.

So i talks out but i can’t get it to talk with the firmware.grandstream.com url.


if you do as I told you it updates, I just yesterday updated 5 DECT752 bases without problem,
post here the screen where you entered firmware.grandstream.com

obviously if your firewall or other impediment does not allow DP752 to properly search for the update, you need to fix the problem on your network.

however you can open a ticket to Gransdtream support:


I’m monitoring the switch port the desc base is connected to so the firewall is not in the game yet.

I’ve posted a screen of the config in the original post.

But again thanks for trying to help me, i might contact support :slight_smile:


Maintenance/Security Settings/Security -> Validate Server Certificates=NO
Manutenzione/Provisioning -> Verify host when using HTTPS=no
Manutenzione/Provisioning -> Verify host when using SSL=no

make these changes, then reboot,
if after a few seconds / minutes all 3 LEDs of the DP752 base flash at the same time, it means that the new firmware is being taken over, obviously do not turn off and let it finish




dear all,

i have tried to update the 752, with HSF programm from to

unfortunatelly something din;t went well and the dect base is always on booting mode, without letting me get into the web interface

could you please help me out… is it possible to fix it or i should go for a new one?

thank you,



Hey damiano,

I figured out that using ISE to authenticate the units before allowing access to the network made them unable to reach firmware.grandstream.com, after moving them to an port without this authentication they could upgrade fine.

Your help was appreciated :slight_smile: