DP752 can't get LAN link


Having trouble with a DP752 (firmware that can’t get a LAN link. It was temperamental at first, but now it cannot link up on LAN at all.

A GRP2613 on the same network port syncs at gigabit and works fine with PoE.


change the port and cable used to connect the dp752 base and reboot the network switch.


There were some that came out setup for http, but required port 443. Go figure.

You might try http://XXX.XXX.XXX.XXX:443 and see if such is the case.


I tried a different port and cable, but the device just doesn’t get an IP address (checked on the DP720 connected and in the UniFi controller).


please contact helpdesk and raise a ticket, it could be hardware defect and if your device is still under warranty, you can get a replacement.


Closing this issue out, the problem was FusionPBX sets a VLAN tag if the “grandstream_lan_port_vlan” variable is set at all: https://github.com/fusionpbx/fusionpbx/blob/master/resources/templates/provision/grandstream/dp750/{%24mac}.xml#L2744

Removing the variable and re-provisioning the device resolves the issue.



“Enable VLAN。 Config to enable or disable virtual LAN. 0 - Disabled, 1 - Enabled. Default is 0 - disabled.

I’m glad you solved it, but I don’t understand one thing,
the parameter listed above identifies whether or not to enable the VLAN on the DP752.

So if I understand correctly you have eliminated the string of the parameter 27004 and now it works,
so either I didn’t understand, or it’s a bug or something doesn’t add up to me.


VLAN tags were getting enabled and set to VLAN ID 0 when “grandstream_lan_port_vlan” was set.

Some routers do not route or provide a DHCP IP address to VLAN ID 0 tagged traffic, while other routers treat VLAN ID 0 traffic as untagged traffic enabling everything to work normally.


in short words. if I understand correctly,
rather than deleting the P27004 string, you have set P27004=0 even though you have to use the VLAN, for your router’s needs,

also because if you eliminate the P27004 string, in reality this setting is present in the DP752 by default, therefore it cannot be eliminated.