DP750 + DP720 - Intermittently DP720's won't ring, DP750 reporting busy


Have you configured the provisioning server or using any TR069 service?


Wow, I’d love to see if this is fixed in a current firmware. All of my 750’s are still on 13.0 because of this problem. (The problem in my original post)

I don’t have any spare 750’s to burn with irreversible firmware to test…

Maybe I’ll pick one up.


Your problem is the device configuration may have changed HS1 Line1 to null after an overnight.
I wonder if you configured any provision server that will check for provision every day, by default is midnight:


Or if you are using our GDMS platform to configured the device on cloud, GDMS server may push setting to the device and change the first line to “None” as well.

The correct setting should be:

Correct Status:

If you configured the device this way and the settings changed overnight, it means there is some provisioning server or GDMS services pushes new settings to your device and messed up the line settings, so your HS1 cannot receive calls.

There is no known bugs related to configuration self-change, our QE team confirmed.


The provisioning server is set to my PBX (freepbx) and is configured via End Point Manager. There are no options in the current EPM device to set HS1, HS2, etc… It just has “save model”. I have ext 1 set for account 1 and ext 2 set for account 2 on the DP750 that was saved in EPM. From the PBX there are no other options to configure lines for HSx so I did that in the DP750 config. I did see a note that a provision server was configured and not to edit on this screen but use the config file instead (dont know where that is) so I turned off “handset config upgrade” and the warning went away.


When I got in this morning


Hi @dajohnso, when you got:

is the Line settings are still correctly as following:

I saw your account 1 and account 2 seems has big difference, are you sure they can use the same profile 1? the profile specify the SIP server, so the account 1 and 2 are both on the same SIP server?


Yes same PBX. .


I am still having this problem. I have done some additional testing and think its something between Sangoma FreePBX End Point Manager and the base. I have set up several DP750’s each with more than one DP720. The issue is that as indicated in the pictures above HS1 gets disassociated with Line 1 almost every night but the problem does not impact HS2, HS3, etc… My current work around is to pair HS1, HS2, HS3 and then just don’t use HS1 at all. I have tried the latest firmware and its still an issue. I also note that there is no way to do the line to HS assignment from EPM which is why I feel like the EPM is causing this issue?
The freePBX is version FreePBX (fairly current on updates) and I have not tried it on FreePBX or FreePBX yet.


so again last night, the first line on HS1 became “unassigned”

This happens all the time and is ONLY happening to HS1 line 1. I added HS3 with the same line and programming and it doesn’t happen. I believe (educated guess) that it has something to do with EPM resetting the 1st line on HS1. I have not found any way to set the line and HS settings in EPM, only on the DP750 (as a VoIP provider I want to me able to program this from the PBX, not have to connect to the base station which could be at a client site). I have checked EPM in version 14, 15, and 16 and none of them appear to have any settings other than the selection of DP750 as the base.


probably on the extensions you have set only 1 simultaneous connection, or you have set DP750 incorrectly


this happens when I have only 1 phone also, I added HS3 as a work around. I have multiple DP750’s and it always happens to Line 1 and HS1. Additionally, for this line there is only 1 DP750 connected. Its the DP that is connecting multiple handsets not the PBX so I don’t understand your point of only having 1 connection configured. Being a “grandstream guru” I would have expected you to ask some questions before stating a blanket “you did something wrong” response. Its happening on all my DP750’s even ones that only have 1 HS and 1 extension setup. Something is causing line 1 on HS1 to get unassociated. I can go back into the base and re-associate it and it will work fine for the rest of the day and be unconnected again tomorrow.


I really don’t owe you anything, as nobody in here owes you anything,
this is a user-user forum, not grandstream support, found in the link below.

I gave you some advice, if I don’t see the problem I certainly can’t
do magic,
moreover we are a company, and for a fee if you want we can learn more.
For free you have to settle for advice, or you are looking for a professional in the area,
gratuitous irony certainly doesn’t help you solve the problem.


I did see some advise here from others not you. You only left one comment of “you did something wrong” and a suggestion not based on the details I gave (i.e. I only had 1 phone so why would I need to increase contacts on PJSIP?) . Wish there was a down vote, your comment wasn’t helpful and your response to me was un called for. You clearly spent more time on your negative comments then you did on reading and trying to answer my initial question.


as mentioned above you can always look for a professional in the area and pay the work and solve,
entering a forum just to offend certainly does not put you in a good light.


If I were you, then remove the DP750 from EPM and then reprogram line 1 to HS 1 and then see if it becomes unassociated again over time. This would tend to indicate that there is indeed an issue with EPM. FPBX 14 is pretty old and whether or not the EPM is tied to versions is not known, but you might also insure that the module is updated.

If you manually program and the settings remain, then it indicates a bug in EPM and perhaps a bug report should be submitted as there would be nothing that GS could do about it.


I have a DP750 setup in FreePBX 15 as well and it exhibits the same issue. I suspect EPM because when you go into the model in EPM->grandstream->dp750 template there are no settings you can change (there is nothing even listed)! I don’t believe the DP750 is even setup correctly in EPM. It appears to wipe out HS1 line 1 only every night.