Downgrade from 1.0.10.39 to 1.0.9.26


#1

Hi All,

I upgrade my PBX to 1.0.10.39 and now I regret it terribly, some of my sip trunks are not registering any more nor my calls are working properly, if someone calls or I make any outbound call I will talk to the person and then after some time (less then a minute) the call will disconnect for no reason. This started happening right after I upgrade to 10.39 code.

Can someone please help or advise If I downgrade back to 1.0.9.26 what could happen will it brick the box?

I also found that calls (both incoming and outgoing) will not last more than 32 seconds.


#2

It states clearly in the firmware release notes that you CANNOT downgrade. This was a major version change that basically had to format and completely rewrite the internals of the system. Also keep in mind that 1.0.9.97 was an interim upgrade that WAS NOT intended for actual usage. The last supported firmware was 1.0.9.26

You are not the only one having issues and I have opened help desk tickets as the GS responses here on the forums have been pretty quite since last week. I am having the trunk registration issues as well. I have not had the 32 second call issue but if things get much worse I will be putting in my hot spare UCM running the previous firmware.

There are enough users here on the forums that are part of the beta test groups and willingly help others to keep this product working/functioning by assisting the less experienced users. Without this level of public support the product will falter in sales, so I am holding faith at the moment that GS is busily working away at a firmware patch.


#3

To give you guys hope, version 1.0.9.26 is a very stable beautiful product. GrandStream is hot right now. They’ll get it right.


#4

So is there any way for me to downgrade. My entire phone SYS is now operating on one of my sip trunk with 32 seconds of call time.


#5

Directly from the release notes directly prior to the actual upgrade instructions:

“Once upgraded to 1.0.10.39, downgrading to any previous version is not supported.”


#6

You very likely cannot downgrade. But that doesn’t mean we can’t solve your issues with the new firmware.

Since the new firmware comes with a much newer version of Asterisk, it’s likely that the under-the-hood changes are causing issues with your NAT router. Calls disconnecting after 30 seconds sounds like an RTP timeout.

Try playing around with the settings on the “SIP Settings/ToS” page. Increase the RTP timeout length.

I would also check your router. Make sure any SIP ALG is disabled.

To troubleshoot, you might consider changing the RTP range (Internal Options/RTP Settings) to a narrower range, like 12000-14000, and then forward those UDP ports on your router. Also try enabling ICE support and STUN support on that page.

Good luck!


#7

Hi There,

I played with all the timers under ToS but not getting any success the call drops right at 32 secs. (both incoming and outgoing).

Thank you for all your help. I just don’t know what else I can do, Please note this was all working great for 4 months with no issues. Nothing was changed on the network. Only starting having this issue right after I upgrade the box.

Not to say couple of SIP trunk are not even registering… I just think the best option would be to rollback just wondering if there is anyone aware of any options.

Thank you.


#8

@smwajih

I recently had a similar problem. 32 seconds seems to be the time the UCM61XX tries 10 times to send a ‘SIP Status 200 OK’ message to the voip provider then sends a ‘BYE’ ending the call. Have a look at my settings that resolved the issue. Basically I needed the following setting in place:
Send PPI Header: Checked

UCM6100 terminates in/out going calls at abt 30 seconds
http://forums.grandstream.com/forums/index.php?topic=29333.msg84939#msg84939

Have a look at my complete configuration. My PBX has been running smoothly since then. No more 32 second cutoff. You might want to do a syslog and a wireshark trace to see if the PBX is sending a ‘BYE’ at the 32 second mark. If you are lucky your voip service provider can offer help from their end. They can tell you what is happening at that moment.


#9

I’ve seen the PPI header as well as NAT cause this issue on the new firmware.

There is no downgrade, but you could buy a different system and then upload the backup to that.


#10

Hi QBZAPPY,

Can you please send me the screenshot for VoIP trunk. I tried to change the settings as per your suggest but not having any luck.

the trunks are from fibernetics who are the owner of freephoneline.

Would appreciate if you can include the screenshot.

Thank you.


#11

@smwajih

Have a look at the images attached. Don’t forget to ‘Save’ and ‘Apply’. Do a reboot just for good measure.

EDIT:
I beleive there are 2 channels offered with Freephoneline (FPL). In the advanced settings you should enter ‘2’ instead of ‘1’ if you want to use both voice channels.


#12

Smwajih, a customer of mine was having the same problem (dropped calls after 30s in or out, but registration was OK) and disabling (“unchecking”) the “NAT” setting in the trunk fixed the issue. The NAT setting works differently between Asterisk 1.8 and 13. The “Send PPI Header” or “Send PAI Header” are for CIDs and need to be checked if you use DODs or your provider uses the CID as part of their validation. So start with by unchecking the “NAT” in the trunk (as is consistent with what QBZAPPY shows) and if that doesn’t do it, then also try the other two settings.

The new firmware works and is really cool. Just that there are some settings that changed behavior so when upgrading you need some time to check everything again.


#13

okay folks, I did what the screen shot says but my calls are still getting disconnected after 32 secs.

I have deleted and re-added the trunk and it does the same thing. No idea what I am missing.


#14

@smwajih

There is more to the recipe than the Trunk settings I referred to in my previous post. Refer back to above mentioned thread. Specifically look at the following settings:

PBX >> SIP Settings >> Misc
Register Timeout: 120 (As per Freephoneline FAQ)
Register Attempts: 0

PBX >> SIP Settings >> NAT
External Host: “DDNS Name:port# of UCM” <-- Do you have a fixed IP address or dynamic.
Use the same port number you set in this section

‘PBX >> SIP Settings >> General>>Bind UDP Port*:5060 (Whatever)’

Ex:
YourExternalIP:5060 (or whatever) If you IP never changes
DDNS_Name:5060 (or whatever) If you IP changes from time to time. You need to setup a DDNS service first, preferably directly on your router.

Use IP address in SDP: Checked

Additional Notes: (My environment)
Router Model: Asus RT-N16 (Firmware TomatoRAF)
No portforwarding on router <-- Enable UPnP to see if it makes a difference
No sip ALG in router just in case <–NOTE Remove this setting for good measure


#15

I did all of this still having the same problem. I have also rebooted the appliance two times. any other idea guys???


#16

@smwajih

It’s time to brush up on your skills. You may want to view the syslog and do a packet capture similar to my other post. See if the packet capture bears any similarity to what I posted or note any differences. I found the syslog harder to interpret. There is so much garbage to sort out before you can try to understand the syslog text file.

These are the tools I used to interpret the

  1. syslog: Notepad++ Portable http://portableapps.com/apps/development/notepadpp_portable
  2. packet capture: Wireshark Portable https://www.wireshark.org/download.html

FWIW I changed the default Bind UDP Port from 5060 to something else.


#17

Okay after all the changes done outbound calls are working the issue is only with inbound calls they get drop after 32 seconds.

Any idea?


#18

@smwajih

Can you make a screen capture of the following web settings on the PBX:
PBX >> SIP Settings >> General
PBX >> SIP Settings >> Misc
PBX >> SIP Settings >> Session Timer
PBX >> SIP Settings >> NAT
PBX >> SIP Settings >> ToS

You may need to make 2 posts because of the 4 attachment limit in the forum.

Before you take the time to make screen captures verify if this setting is checked:
PBX >> SIP Settings >> NAT
Use IP address in SDP: CHECKED


#19

Thank you for all your help. Attached are the screenshots.


#20

@smwajih

The message bubble to the left of
PBX >> SIP Settings >> NAT>>External Host:
reads as follows: “Configure a static IP address and port (optional) used in outbound SIP messages if the PBX is behind NAT. If it is a hostname it will only be looked up once.”

The part that says it will only be looked up ‘once’ makes me unsure. It may not change anything, but to align your settings more to my my PBX which has no issues try the following changes:

  1. PBX >> SIP Settings >> General Change ‘Bind UDP Port:’ Ex 5090
  2. PBX >> SIP Settings >> NAT >> External Host: DynDNS:5090 (NOTE IMPORTANT include port number)
  3. PBX >> SIP Settings >> Session Timer<-- REMOVE checkmark
  4. PBX >> SIP Settings >> ToS>> 100rel: Yes
  5. Make certain all the firewall rules are NOT active ‘Settings >> Firewall >>’

A shot in the dark if above fails try these additional settings:
PBX >> SIP Settings >> ToS
Trust Remote Party ID: Checked
Send Remote Party ID: Checked

If still no luck, with above mentioned settings try using another router to see.